XEN Virtual control panel hang

When I click on the Yast2 -> Virtualization -> Virtual Machine Manager, the windows goes up and close immediately

I test under KDE3 and KDE4 and in text mode with the same way

If I open a console and type xm list i saw my virtual Machine running or Stopped

Any suggestion ?

I test with the OpenSuse 11.0 32bits Version without any trouble the Virtualization work fine and the Virt-Manager.py 0.53 works
It seems that something wrong in the 64Bits Opensuse.
The machine I use is a DELL Optiplex 740 AMD Athlon X2 64 with 2Gb of RAM

Do you know what I must change to have the virt-Manager working fine in the 64bits

A very similar thing was observed on a PC with Opteron and openSUSE-11. Before installing any vm, the “Virtual Machine Manager” window could be opened. Installing a Windows 2000 vm reached the step to reboot Windows 2000 and complete the installation. The reboot did not seem to the final stage. Trying to install again using the same name would be blocked by a message saying the vm already existed.

After that, trying to open the “Virtual Machine Manager” window would cause it to pop up but immediately close. The window would seem to show a vm with 0% CPU and memory usage. The same is true after rebooting openSUSE-11. Each such try would generate a message in file “.xsession-errors” like the following one:

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x3400003 (Virtual Ma)

Any suggestions about what I should try the next?


The case I discussed in my last post clearly involves a failed install. The first reboot into the Windows 2000 vm did not complete and so did the installation. However, the case in the first post may have a good running vm. Therefore, the two cases could be different.

I have found another post discussing a case similar to mine at
Xen: Error - No kernel was found… - openSUSE Forums
In that case, the first reboot to complete the installation of a linux vm did not complete, and clicking the “Virtual Machine Manager” icon would cause a window to flash and then disappear. The differences with my case are: the vm is a linux vm, and the machine has a Intel x86 chip.


I am using 64bit openSUSE 11 and get the same problem with Virtual Machine Manager, just briefly opening and then closing. However I can run it without issue calling (python /usr/share/virt-manager/virt-manager.py -c xen:///) it from a terminal window as root. I noticed that Create VM works correctly in gnome but asks for root credentials first whereas VMM does not. Any suggestions why Virt-Manager fails to ask for root permission when starting in the gui?

Discovered the problem lay with the /usr/share/applications/YaST2/virt-manager.desktop file. Seems it did not get created/written correctly, compared to other .desktop files the contents were both out of sequence and incomplete. Copied the vm-install.desktop file renamed/amended appropriate values, logged out and back in and it now works from Gnome.

Can you please post an example of the corrected file ?

Contents of working file:- virt-manager.desktop

[Desktop Entry]

X-SuSE-YaST-Call=/usr/bin/virt-manager -c xen:///


Exec=/usr/bin/virt-manager -c xen:///

Name=Virtual Machine Manager
GenericName=Virtual Machine Manager

Name[ro]=Creare maşini virtuale
Name[gl]=Crear Máquinas Virtuais
Name[da]=Opret virtuelle maskiner
Name[pt_BR]=Criar Máquinas Virtuais
Name[ru]=Создание виртуальных машин
Name[pl]=Tworzenie maszyn wirtualnych
Name[cs]=Vytvořit virtuální stroj
Name[uk]=Створити віртуальні машини
Name[ko]=가상 머신 만들기
Name[fi]=Luo virtuaalikoneita
Name[de]=Virtuelle Computer erstellen
Name[sv]=Skapa virtuella maskiner
Name[pt]=Criar Máquinas Virtuais
Name[nb]=Opprett virtuelle maskiner
Name[wa]=Ahiver des forveyous éndjins
Name[hu]=Virtuális gép létrehozása
Name[es]=Crear máquinas virtuales
Name[nl]=Virtuele machines aanmaken
Name[sk]=Vytvoriť virtuálne stroje
Name[it]=Crea macchine virtuali
Name[et]=Virtuaalmasinate loomine
Name[fr]=Créer des machines virtuelles
Name[pa]=ਵੁਰਚੁਅਲ ਮਸ਼ੀਨਾਂ ਬਣਾਓ
GenericName[ro]=Creare maşini virtuale
GenericName[gl]=Crear Máquinas Virtuais
GenericName[da]=Opret virtuelle maskiner
GenericName[pt_BR]=Criar Máquinas Virtuais
GenericName[ru]=Создание виртуальных машин
GenericName[pl]=Tworzenie maszyn wirtualnych
GenericName[cs]=Vytvořit virtuální stroj
GenericName[uk]=Створити віртуальні машини
GenericName[ko]=가상 머신 만들기
GenericName[fi]=Luo virtuaalikoneita
GenericName[de]=Virtuelle Computer erstellen
GenericName[sv]=Skapa virtuella maskiner
GenericName[pt]=Criar Máquinas Virtuais
GenericName[nb]=Opprett virtuelle maskiner
GenericName[wa]=Ahiver des forveyous éndjins
GenericName[hu]=Virtuális gép létrehozása
GenericName[es]=Crear máquinas virtuales
GenericName[nl]=Virtuele machines aanmaken
GenericName[sk]=Vytvoriť virtuálne stroje
GenericName[it]=Crea macchine virtuali
GenericName[et]=Virtuaalmasinate loomine
GenericName[fr]=Créer des machines virtuelles
GenericName[pa]=ਵੁਰਚੁਅਲ ਮਸ਼ੀਨਾਂ ਬਣਾਓ

I am still encountering this issue with KDE-4. I have installed using a DVD and have run all of the updates that I can find but my Virtual Machine Manager still won’t open from the YaST console.

Now, I might have missed something as I’ve never used SUSE before last week. I tried the file that was listed in the previous post, however it didn’t work either (Though I am fairly sure that’s more due to it being a fix for Gnome, and not KDE).

Anyone have any more ideas?


I have had the same problem…
Somebody have forgotten to make dependency to some svg library in my case…
in the log file i found following error:
Couldn’t recognize the image file format for file ‘/usr/share/virt-manager/pixmaps/virt-manager-icon.svg’

So I looked for svg packages, and installed them… (I do not exactly witch was missing) and it started to work…

Please who knows witch package was missing, tell it here, and it should be put to the xen-tools rpm dependency list!

tried only app, librsvg and libsvg - now works - maybe only last one will already be sufficient.