Xen gui Suse 11

Hello I am running Suse 11 on an Acer 1524Wlmi freshly built with KDE. Having installed all the prequiste packages to run Xen on my notebook, I can’t get the Xen O/S to boot into the gui, its command line or death.,

Having trawled the web, I have deduced that I need the required Nvidia modules to work in the xen domain when booting ( nvidia modules work fine, 3D good in none xen Suse 11).

Can anyone tell me how to go about this, packages or otherwise that need to be installed, everything else works fine as far as I can see,



Hi there,
I have the same problem. Does anyone have any ideas?


I had this problem as well. If your situation is the same as mine it is very easily solved.

Open /etc/X11/xorg.conf with a root file manager, scroll down to:

Section “Device”

In there change the line:

Driver “nvidia” to

Driver “nv”

Reboot into the Xen kernel and it works.

NB. Back up your old xorg.conf first in case it doesn’t get done automatically.

Hm. I tried change drive “nvidia” to “nv”, but this option is to normal OpenSUSE booting, not only for Xen. Can I create separate mode for Xen booting? Nv not supported 3D.

If you are booting normal suse then use an ‘nvidia’ xorg.conf, if you are booting Xen then use an ‘nv’ xorg.conf.

Unfortunately I don’t know a way to change between them automatically.