xen guest machine fails at boot


recently i tried to reboot one off my vm’s, this was done using “xm reboot servername”
After this the vm crashed and refused to reboot
command used:

  • xm start servername
  • xm resume servername
  • xm reboot servername

The status changes from r => b => p,c,d

below are a few examples of the errors i got.
Hope somebody can help.
Thanks in forward.

log examples

output of guest system

0.168779] PCI: Fatal: No config space access function found
0.169363] Unable to read sysrq code in control/sysrq
1.306195] i8042: No controller found
1.307994] /home/abuild/rpmbuild/BUILD/kernel-xen-3.7.10/linux-3.7/drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
1.965074] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00
1.965121] Pid: 1, comm: sh Not tainted 3.7.10-1.16-xen #1
1.965145] Call Trace:
1.965177]  <ffffffff80008ae5>] dump_trace+0x85/0x1c0
1.965205]  <ffffffff804f8449>] dump_stack+0x69/0x6f
1.965232]  <ffffffff804f9566>] panic+0xc7/0x1e5
1.965258]  <ffffffff80035165>] do_exit+0x7d5/0x8c0
1.965285]  <ffffffff800355ba>] do_group_exit+0x3a/0xe0
1.965311]  <ffffffff80035672>] sys_exit_group+0x12/0x20
1.965339]  <ffffffff8050ad0b>] system_call_fastpath+0x1a/0x1f
1.965375]  <00007f22e7675929>] 0x7f22e7675928

qemu-dm log file output

domid: 10
Warning: vlan 0 is not connected to host network
char device redirected to /dev/pts/1
xs_read(): target get error. /local/domain/10/target.
xs_read(): vncpasswd get error. /vm/5ff8215f-86c2-ebe9-00ea-648c010f5c84/vncpasswd.
char device redirected to /dev/pts/2

Anybody got an idea?
I tried a few times to create/install a new machine.
The installation process runs, but on completion it stops and destroys the machine.
Hope someone can help me with this issue.

For starters, this seems to be very obviously a problem releated to virtualization and not a general boot question, so you posted to the wrong forum. You’d probably have gotten more eyes on it if you posted to the Virtualization forum.

But, your specific problem…

0.168779] PCI: Fatal: No config space access function found

It’s hard to tell if this first line of your stdout (I assume) is sufficient to pin-point your problem, but from this I assume that your VM config file isn’t providing sufficient information… And I imagine many postential causes because there is nothing listed prior to this line. Could imply the config file is corrupted, missing a parameter, your Xen install damaged, much more.

I guess for starters, I’d wonder if any other VMs run on this machine and if so if they’re having any problems. Depending on whether this is a widespread or VM-specific problem, I’d then take a closer look at the various possible causes (and again, if there is any output prior to what you quoted, it might be helpful either in understanding the exact point the boot process failed, possible leading causes, etc).