XEN boot error


this is a new installation of openSUSE-13.2 with XEN-4.4.

When booting openSUSE-13.2 with XEN hypervisor the boot logging on the console shows only the the upper part of the lines.

When switching to graphical login the screen is messed up.

Booting openSUSE-13.2 w/o XEN works fine, so I assume its the graphic card.

The graphic card:
~ # lspci -nnk | grep VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0042] (rev 12)
Subsystem: ASUSTeK Computer Inc. Device [1043:8383]
Kernel driver in use: i915
~ #

XEN was runnung ok with openSUSE-11.3 with this machine.

The same installation runs well on another machine with this graphic card:
~ # lspci -nnk | grep VGA -A2
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550] [1002:954f]
Subsystem: PC Partner Limited / Sapphire Technology Device [174b:0e13]
Kernel driver in use: radeon
~ #

Any hints would be very much appreciated.

I would change the thread name since it is most likely not a boot error since I guess the machine boots successfully.

Second, I would suggest you try a different VGA mode for booting since yast-boot might not be that smart: YaST2 -Boot Loader --Boot Loader Options

Third, I would suggest you try and open a ticket to report a bug: https://en.opensuse.org/openSUSE:Submitting_bug_reports but it might not be an openSUSE issue.

Did you try the safemode for XEn which should activate “nomodeset”?


Other relevant info:

Thanks for your reply;

How can I change the thread name?

I tried savemode;
after the display switches to smaller fonts, the the lower part of the lines are cut and it hangs with

kernel: floppy0: no floppy controllers found
kernel: work still pending

That’s correct, the machine has no floppy attached, why does the xen-kernel search for a floppy controller then?


Now I booted opensuse-13.2-xen with dbg,

Command line: root=UUID=435aff07-87b5-4961-a729-5a99c3ade4b7 ro resume=/dev/disk/by-uuid/... splash=silent quiet showopts vga=normal

The console output is still halfline only and the Xwindow login screen is distorted.
Keyboard entry is not possible.
[LEFT] [LEFT]It is however possible to login over XDMCP.


Since this is a new virtualization install, did you immediately update your system?
Although undocumented, it’s my SOP.

zypper up

Then, reboot and try again.


I did ‘zypper up’ and it replied ‘Nothing to do’


Recommend you next try force re-installing your xen and libvirt packages

Obtain a list of your xen packages

zypper se xen

Optain a list of your libvirt packages

zypper se libvirt

Create a list of the above packages and execute the command

zypper in -f *packagelist *

Do a “zypper up” and reboot again.


Thanks for your time TSU.

However I reinstalled complely already.


Is OK.
If it’s a brand new “everything” then it’s a logical option.


Installed a PCIx graphic card and it worked.
Apparently xen-kernel 4.4.3_02-30.1 cannot handle the internal graphic card (RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller).
Non-xen is booting ok.