Xen 4.0 and OpenSuse 11.3... Cannot view graphical console...


everything is a breeze with xen and opensuse… but one thing… I CANNOT make it run, which means whenever i tried to create a new vm or guest OS… it will logout… and then when i log back in… the guest OS or DomU has been created in the virtual manager… however if i try to open the guest machine to view the graphical console… it logouts again… i reinstalled too many times now… so frustrated… anyone experienced this??? thanks…

Try it:


VirtualBox & Wmware Player are good choice too!!

Actually it does boot into xen kernel successfully… but everytime I want to open Virtual Guest’s graphical console… the system logs out… I need to login again into OpenSuse (with Xen kernel of course)…

I just downloaded the latest version Virtualbox… Planning to use it now… thanks…

I am having exactly the same issue here. Let me restate the problem…

OpenSuse 11.3. All updates applied.

I can boot into the XEN kernel no problem. Fire up virt-manager and install a domU, all appears fine. If I then disconnect from the vm’s console by closing virt-manager and reopen it, virt-manger opens sucesfully, however when I attempt to reconnect to the vm, the virt-manager window instantly closes instead of displaying a console. The same behaviour also occurs if I select to view the details of the virtual machine instead of opening the console.

If I reboot the domU from within virt-manager I can again connect to the console, view vm details no problem. One time. When I disconnect from the console the issue recurrs until I perform another reboot of the vm via virt-manager. I should also point out that after the issue has occured the domU continues to run in the background. I can connect to the console via ssh, it will reply to pings etc.

So to sum up, cant connect to vm or view details after disconnecting from a virtmanager session without rebooting the domU.

As far as troubleshooting goes nothing is logged to messages, xend-debug.log or xend-log as the issue occurs.

I have tried creating Solaris10 and Win 2003 fully virtualized hosts but both exhibit the same issue.

I would really like to have XEN working as I plan to use paravirtualization in the future, so Virtualbox or something similar isn’t really an option.

I am not sure if these are relevant but here are some warning/errors from dmesg:

<4> 0.283317] Failed to disable AUX port, but continuing anyway… Is this a SiS?
<4> 0.283318] If AUX port is really absent please use the ‘i8042.noaux’ option.

<4> 4.313948] ACPI Warning for _PR_.CPU2._PSD: Return type mismatch - found Integer, expected Package (20100121/nspredef-1053)
<3> 4.313952] ACPI: Invalid PSD data
<4> 4.314208] ACPI Warning for _PR
.CPU3._PSD: Return type mismatch - found Integer, expected Package (20100121/nspredef-1053)
<3> 4.314212] ACPI: Invalid _PSD data

<4> 4.624522] [drm] nouveau 0000:01:00.0: 0x71B3: Condition still not met af
ter 20ms, skipping following opcodes
<4> 4.648519] [drm] nouveau 0000:01:00.0: 0x71B7: Condition still not met af
ter 20ms, skipping following opcodes
<6> 4.648556] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 1 at offs
et 0x7391
<6> 4.672018] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 2 at offs
et 0x810E
<6> 4.672030] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 3 at offs
et 0x8130
<6> 4.722219] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 4 at offs
et 0x8292
<6> 4.722222] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table at offset
<4> 4.744527] [drm] nouveau 0000:01:00.0: 0x6D79: Condition still not met af
ter 20ms, skipping following opcodes
<3> 4.744539] [drm] nouveau 0000:01:00.0: Couldn’t find matching output script table
<6> 4.744645] [drm] nouveau 0000:01:00.0: 0x5766: parsing output script 0
<3> 4.744649] [drm] nouveau 0000:01:00.0: Couldn’t find matching output script table

Any suggestions welcome. I will try and post results here.


I have just checked virt-manager.log expecting to find errors here but all that is logged just before virt-manager crashes is the following:

[Mon, 11 Oct 2010 13:21:04 virt-manager 4263] DEBUG (engine:630) window counter incremented to 2
[Mon, 11 Oct 2010 13:21:04 virt-manager 4263] DEBUG (console:654) Starting connect process for vnc://localhost:5900: localhost 5900
[Mon, 11 Oct 2010 13:21:04 virt-manager 4263] DEBUG (console:492) VNC initialized

This is basically what is logged upon the first connection when it succeeds so it tells us nothing.

If I manually run vncviewer, ie, vncviewer localhost 5900 I can connect to my vm when virt-manager fails. While this is a workaround, I still can’t view my vm to modify properties unless I reboot the guest. Looking for answers. Thanks.


I have exactly the same problem. What;s interesting I had the same behavior on Fedora + KVM. Maybe it’s something wrong with my server?


Hi All,

Yes I see the same problem it seems to be worse when you are running more than one VM.

I can reliably recreate the problem be starting a VM and opening its console. Then starting a second VM and opening its console this all seems to be fine.

Then I close one of the consoles. I can then try to open any other RUNNING VM’s console and details and it pops up the console and details Window for a split second appears to show some garbage on the screen and then the whole virt-manager appears to crash. However if I open a VM that is NOT running then the console and details window opens fine and if I start running it the console display appears to be stable.

So the problem appears to be related to reconnecting to a VNC console that is already running.

I also do not see any logs related to the failure but maybe its hitting a terminal error handler that reports nothing.

I am running on a single processor six core 4180 CPU with 8GB of RAM and just VESA graphics.

As this bug is so easy to replicate I am suprised it has not already been found and addressed maybe someone from OpenSuSe/XEN development can weigh in on what is going. Any way around it. Or when a fix will be available??

Is there any other Thread o this or another forum covering this issue??

Is it also possible that this is related to what seems to be a broader issue on recent versions of OpenSuSE related to VNC stability that seems to server side related??

Will continue to spend a bit more time researching this and post any progress.

Hi All,

Investigated a bit further and when virt-manager is run at the command line it is getting a segment violation that is causing the problem we are all noticing. I have not investigated where the segment violation is occurring or why as I really do not have days or weeks to spend on this.

Just unfortunate this was not noticed prior to release.

I noticed that there is a newer version of the VMM out there 0.8.5 but despite much Linux experience and hours trying I cannot get it to operate. The issues seem to be related to all the dependencies in the Python **** that needs upgrading to run it.

Decided to try OpenSuse 11.4 milestone 4 to see if the issue is addressed here. At least if it is not hopefully someone at Novell or in the development community will take an interest in looking into the issue and fixing it.


I have the same problem but only with “not Suse guest” RHEL4 and 5.
All Suse 11.3 guest’s working fine!


A little strange is that the output from virt-viewer (on working VM!!) exactly the same:

$# virt-viewer -w –reconnect SUSEGUEST
Xlib: extension “RANDR” missing on display “::1:1.0”.
xpath.c:14872: XPath error : NULL context pointer
but works fine (I can see the vm console)

$# virt-viewer -w –reconnect REDHATGUEST
Xlib: extension “RANDR” missing on display “::1:1.0”.
xpath.c:14872: XPath error : NULL context pointer
→ virt-manager crash….

Did anyone get this working? I still have the same problem, I cannot open a console without it logging out


No solution but an workarround.

I use vncviewer instead of virt-viewer. After the crash of virt-viewer ( or virt-manager ) vncviewer also crash on the first try. But after the the second try i can successful access the vnc-console using vncviewer.

If you’re using a vm “locally” - guest and host on the same machine - you can remove the vnc display and replace it with sdl. It’s a bit better too . But of course you can not access the vm remotely.

  • well, with kvm, I mean. But I guess it should be possible with Xen too.