XDMCP not working on 12.1

With 12.1 (i586) I cannot get XDMCP to give me a remote X11 login. I’ve checked and double checked the configuration files (unless I don’t know them all) and I’ve tried all displaymanagers; xdm, kdm, wdm, and gdm.

I use Xming on a Windows 7 (x64) machine as my primary workstation, and I operate all of my other machines remotely. I only have room in my apartment for a single console. xdm, kdm, & wdm will not give my Windows machine a XDMCP logon. All three of them work fine locally with a console to the openSuSE 12.1 machine.

gdm will give me a XDMCP logon window on my Windows machine, but it will not accept any keyboard or mouse action without issuing an error window “Oh No! Something has gone wrong.” It gives the local console a logon window, which flashes every minute apparently changing the refresh rate.

With prior versions of openSuSE I used kdm to get XDMCP working. I rebuilt my 11.3 machine as a 12.1 machine.

Oh, I am able to get a SSH text window from Windows to openSuSE.

same thing here…

i am not even able to do anything in the login screen. whenever i select to login via xdmcp, the dialog appears and even lists the available machine to log in, but as soon as i do anything (moving the mouse, hitting a key, whatever), the dialog seems to crash and the normal login screen is back…

i used to do this with 11.3 or 11.4 the last time, and back then, it worked… those were the good old days…

just found the bug report for this issue: https://bugzilla.novell.com/show_bug.cgi?id=715265

hemathor - I started this bug for SuSE but the issue is really in KDE and has been logged from several other distros; see KDE bug 281862. It was introduced in KDE 4.7.x and is already reported to still exist in the new KDE 4.8 from other distros as well. If you really need the feature, stay at KDE 4.6; I am not sure if there is a path to 4.6 if you have installed 12.1

mfaklis - Your issue sounds different. Are you aware that XDMCP is not enabled in a fresh install? These are my notes-to-self on how to enable:


  1. XDMCP     Setup
1.Edit /etc/sysconfig/displaymanager 
Change     to:
2. Edit     /usr/share/kde4/config/kdm/kdmrc
Change to:
#     Whether KDM should listen to incoming XDMCP requests.
# Default     is false
3. Edit the Suse firewall settings,     either open ports or shut it down depending on your situation
4.     SuSEconfig or reboot 


Due to the above bug I have been unable to verify the above process still works, but these fields still exist in the 12.1 config files.

Give the above a try