XDM - blank screen (except cursor) on Leap 42.2

Posting here as it is a login problem (via XDM).

I have an optimus laptop which has the suse-prime package installed as well as Nvidia drivers from the nvidia repo.

Everything seems to work ok in that I can “prime-select intel” and X will run as well as xdm being operational as normal. However, with “prime-select nvidia” I can run X with “startx” and verify that the nvidia drivers are being used, however xdm produces a blank screen when i “service xdm start”. I suspect something is off with xdm considering that I can startx without it.

Any help appreciated. Thanks.

You seem to have a slight misconception here.

The xdm service (which doesn’t exist btw, it’s actually called display-manager nowadays) does not (necessarily) start xdm, but rather the DISPLAYMANAGER configured in /etc/sysconfig/displaymanager.

That may or may not be xdm, according to what you chose during installation.

So please post the value of that setting for a start.

Also, the preferred way to start a service is systemctl nowadays. In this case:

systemctl start display-manager.service

What I suppose is happening here is that you are actually using sddm, but for some reason nvidia’s OpenGL support doesn’t work.
sddm requires OpenGL because it uses QML for its theming.

You may want to try setting DISPLAYMANAGER=“xdm” in /etc/sysconfig/displaymanager to really use xdm.

OTOH, you may check whether OpenGL support is working when you run startx with nvidia.
Install the package “Mesa-demo-x” and run “glxinfo”.

Ok. Thanks for the tip. I presume systemctl is a systemd thing.

glxinfo produces what I would say is expected output. Here is an example:


...
OpenGL vendor string: NVIDIA Corporation                                                                                                                                                                        
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2                                                                                                                                                              
OpenGL core profile version string: 4.5.0 NVIDIA 375.20                                                                                                                                                         
OpenGL core profile shading language version string: 4.50 NVIDIA                                                                                                                                                
OpenGL core profile context flags: (none)                                                                                                                                                                       
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
...

I tried changing DISPLAYMANAGER in /etc/sysconfig/displaymanager to kdm and xdm, but the result is the same. I am not particular if it is sddm or whatever, although sddm being QML based seems rather nice.

Thanks.

I was experimenting with different Display Managers on a machine today, and xdm resulted in a bare Openbox environment (no panels, no background, only color, no way to launch anything except a windowed console) so if you really did somehow configure something like this, you wouldn’t be very happy.

Although there are several proven DMs you can choose from, most often Lightdm is the one generally recommended if you don’t know what to choose and the installed Desktop didn’t select one for you.

Also, at least on this machine that has LXDE and LXQt installed, xdm was not installed by default and had to be installed to be tried.

TSU

Hi TSU,

I don’t know what an “Openbox environment” is, but perhaps I should clarify. What I am seeing is a blank or black screen with what appears to be a console type cursor in the upper left corner of the display. What I am NOT seeing is X running with an X mouse-cursor but with no window manager.

You’re seeing exactly what you describe – an empty console … nothing is running on it currently

Well it certainly is not for lack of trying. X starts with starx but xdm, kdm, sddm and the like don’t.

All of them don’t work?
Wow.
Definitely not an OpenGL problem then…

Anyway, sounds similar to the problems OrsoBruno described here:
https://forums.opensuse.org/showthread.php/512260-Leap-42-1-Optimus-system-with-nvidia-prime-instead-of-bumblebee?p=2803085#post2803085

Does it help if you enable Auto-Login for the DM?
I.e. set DISPLAYMANAGER_AUTOLOGIN=“username” in /etc/sysconfig/displaymanager.
(won’t work with xdm though, you’d need to use one of the others…)

I guess not. Worth a shot though. I did notice that the “spinning semi-circle busy indicator thingy” spins unusually fast for some reason.

Indeed it seems to be the same issue described there. Setting DISPLAYMANAGER_AUTOLOGIN=“username” does work so I guess it will serve as a workable solution. I don’t know what I like better, autologin or just making X suid and using startx.

Anyway, thanks for the link and tips. Much appreciated.