XCOM 2 on Steam won't start

More of a rant, than anything else. As per topic, I’ve been trying to run this game, and some others, with various degrees of success. But XCom 2 is not running at all.
Right now it complains about some libraries (which are in game’s folder under lib) not being found.
If I add that folder to LD_LIBRARY_PATH, it complains about some other libraries not having expected version info.
I’ve tried prefer host libraries override, running Steam under X11 and Wayland.
I’d love to use Linux as much as possible, but for 10 or so years I’ve been dabbling in it, it’s always an uphill battle, one thing being fixed two others borked.

Thanks for reading my rant. If by some miracle you know why XCom 2 is not running, or even how to fix it, please help me out.

This works for me, rename for ex: /.local/share/Steam/steamapps/common/YOURGAMENAME/lib/x86_64/libcurl.so.4 to libcurl.so.4.bak this works for every Feral games.

For other like Tomb Raider: /home/romi/.local/share/Steam/steamapps/common/Tomb Raider/lib/i686/libcurl.so.4 also to libcurl.so.4.bak

This command might also work:

But never tested.

Thanks for suggestion, if I remove libcurl from XCOM 2/lib/x86_64/ I get this:

/usr/lib64/libcurl.so.4: no version information available (required by ~/.local/share/Steam/steamapps/common/XCOM 2/bin/XCOM2)

and it still does not start.
If I run steam with STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0, I get this:

~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_4' not found (required by ~/.local/share/Steam/steamapps/common/XCOM 2/bin/XCOM2

And it is still going nowhere.
If I leave libcurl as it is in XCOM 2/lib directory - I get complaints about libs required by libcurl.so.4 (no version information available).

Strange the only games I have from Feral Interactive are: Tomb Raider, Company of Heroes 2, Middle-earth: Shadow of Mordor, GRID Autosport, Mad Max, Warhammer 40,000: Dawn of War II.

And all of them are working by renaming libcurl.so.4 or remove it.

I posted some time ago a workarround on github some time ago not sure if works or not anymore: https://github.com/ValveSoftware/steam-for-linux/issues/4537#issuecomment-265642477 this might work for you

I agree it is a problem especially if you are a gamer. On the bright side the situation is much better than 10 years ago. Wifi drivers as the most vivid example come to mind (ndiswrapper and using windows drivers was fun). Another benefit of this is whenever you run into problems you can learn a lot from it :slight_smile: