XBMC running on SuSE 13.1 can't see an NFS share?


I have just posted the following question over on the XBMC Forum. It has since occurred to me that as I am using the pre-compiled RPM from the Packman Repo, is it possible that it has been compiled without an “NFS” option flag - if such exists?

Best regards, Martin

I have an NFS share. I can use that share to provide media to XBMC  running on my Raspberys (Raspbmc 12.2), and Android tablet (Also 12.2).

However, I can't access that same share from SuSE 13.1 workstations? 
On the above (Raspberry/Android) platforms, I am able to browse/drill down to the required  NFS location, while at the workstations, in the "Browse for new share",  clicking the NFS option does nothing that I can detect?

BUT, these same workstations, are able to access and mount the NFS share perfectly well from within the OS?

The NFS share export is:
$cat /etc/exports
/nfs    *(rw,all_squash,insecure)

And the permissions on the /nfs directory (and all below) is:
$ls -l /nfs
drwxrwxrwx 65 nobody nogroup 4096 Dec 16 16:24 myMusic
drwxrwxrwx 27 nobody nogroup 4096 Sep 14 22:14 myMusic.flac
drwxrwxrwx 76 nobody nogroup 4096 Nov  6 18:46 ourPhotographs
drwxrwxrwx 20 nobody nogroup 4096 Dec 18 11:58 ourVideos

I have read [NFS - XBMC](http://wiki.xbmc.org/index.php?title=NFS) but can find no other clues to investigate.

Looks like the packagers forgot a dependency. I installed libnfs, now I see the nfs server’s ip and the exports.

EDIT: can’t access them though. FYI Firewall is off, on both server and client, so that’s not the issue.


Thank you. Easy when you know how. Eh…

Regards, Martin

PS - Do I need to tell anyone?

Looks like we cross-posted, I can’t add the shares as locations. Editted my post already. Does this work for you now? That would be weird.

Yes. Like a dream! When setting up my source (music and video) I could drill down as needed. Once the source was set, I am able to play (audio & video).

I had, however, previously set the permissions on the nfs share and contents to “nobody” and “nogroup”.
That was need for my Androids, as a consequence of the settings in /etc/exports ( see first post in this thread).

Regards, Martin