XBMC 12.0-2.1 Crashes at startup on openSuSE 12.2 with Undefined Symbol Error

  1. Using openSuSE 12.2 with all latest updates
  2. Downloaded and installed latest release of XBMC (12.0-2.1) using Apper
  3. Opened console window and typed command “xbmc”
  4. XBMC does not start and displays the following error:

dmullins@linux-cart:~> xbmc
/usr/lib64/xbmc/xbmc.bin: symbol lookup error: /usr/lib64/xbmc/xbmc.bin: undefined symbol: _ZTIN6TagLib5ID3v219Latin1StringHandlerE
dmullins@linux-cart:~>

  1. This occurs on 32-bit AND 64-bit systems
  2. Apper install upgraded previous version of XBMC (11.0-4.31)

Cannot use new XBMC 12.0 release on openSuSE. Works OK in Windows XP.

I built it myself using the source rpm from packman and it works fine. Perhaps try reinstalling it using yast instead of apper?

This combo is impossible. On 32bit systems there should be no /usr/lib64/xbmc/xbmc.bin

Please post output from a both a 32bit and a 64bit system


uname -a
rpm -qa  | grep xbmc

I get the same error too. XBMC fails to load.

jh@linux-n6ky:~> uname -a
Linux linux-n6ky.site 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux
jh@linux-n6ky:~> rpm -qa | grep xbmc
xbmc-12.0-2.1.x86_64

Installed from YAST.

libtag is to blame. Open yast > search libtag1 > versions > chose 1.8 from Packman. Resolve dependency issues by changing repos. Problem solved.

Thanks working now…

Glad I could help.

BTW, do you know anythng about this add-on for XBMC 12?

xbmc-pvr-mythtv-cmyth

It’s not in the OS community repo. But is in Ubuntu’s.

I would like to use XBMC 12 with MythTV backend only to see that the MythTV add-on is not included in XBMC 12.

Please don’t compare Ubuntu to openSUSE. Sometimes packages differ. In this specific case it’s even more difficult to say anything decent, since it’s a new XBMC (changes have been made in handling PVR). AFAIK Packman deals with the myth packages.

Appreciate the solution, it works perfectly!

This solution helped me as well = thanks