XBitHack for Server Side Includes in Apache 2.2 on 64-bit openSuse 11.3--can't

Have tried several ways to set SSI on my 11.3_64 server, including Yast, httpd.conf, and .htacess in both /srv/www and /srv/www/htdocs. Still get a log entry each time I access the main file from another machine: [Mon Nov 22 23:17:13 2010] [warn] [client] mod_include: Options +Includes (or IncludesNoExec) wasn’t set, INCLUDES filter removed

In http.conf there is
<Directory /srv/www/htdocs>
Options +Includes
XBitHack full
SetOutputFilter INCLUDES
AllowOverride All
Order allow,deny
Allow from all
AddType text/html .html
AddOutputFilter INCLUDES .html


Have tried similar config instructions for the XBitHack function in a .htaccess file on a hosted linux server that does SSI for files with the .shtml extension.

The XBitHack doesn’t seem to work on either machine. Every tutorial on SSI seems to have a different “secret sauce” to make it work: file names in all lower case, don’t forget the space before the final -->, use XBitHack rather than a .htaccess file, don’t touch httpd.conf but put commands in .htaccess. Most confusing.

Anything jump out at you? Suggestions appreciated.