Xauthority problem

Hi! I’ve installed tumbleweed server, so i could start with a version with few packages. I’ve installed gnome, and enabled gdm service, but when i boot gnome doesn’t start automatically. I have to:

  • login in the shell
  • delete .Xauthority
  • give startx command

How can i solve this problem with Xauthority?

Please explain more detailed.

  • after boot, do you get the gdm login screen?
  • when you get the login screen, what happens when you fill in the credentials there?

Hi, no i don’t boot in gdm screen, just in the terminal login. Nothing is displayed because the x server is not started i think. So i first have to login from there, then if i try to startx it says that there are problems with Xautorithy, i have to remove .Xauthority file and then startx.

A particular: if i do the login, remove .Xauthority and then startx it doesn’t work, i have to try a startx (that fail) before remove .Xauthority, and then retype startx.

OK, thus your gdm does not start.

You say you have “enabled gdm service”. How did you do that (In general such vague statements as “I did something” gives no information, always tell what you did with which tool).

Also, when I understand correctly, you first installed this as a text only system (you call it “server”, a likewise vague word) and then installed Gnome (again, how? by using the Gnome pattern from YaST or with zypper). But now you want to run a graphical system and thus your run level must be adapted. You can choose that in YaST > System > Services manager, at the top.

Changing to “graphical interface” in Services manager solved all, thanks!

I enabled gdm service with

sudo systemctl enable gdm.service

I would like a system more minimal as possible, with just few packages, so i can add only the packages i would like to use (and dependencies).

I don’t know if you have OpenSuse installed at this point, but during the installation process you have to choose which type of environment you want to install, so you can install Gnome, Kde, something else, or “Server”, this is the exactly word next to the box to select. Have i to report developers the error?

Fine that it now works as expected!

One does not install from scratch that often, thus I realy do not know any more what all the choices are. I know that earlier (many years ago?) you had something like KDE, Gnome, …, X-only, Text only. For me it is very clear what you get then.

When it is now “Server” I would realy not know what that means until I tried it. IMHO Server is a much misused (often by journalists) word for any computer that is not MS Windows, but something in a computer room.
For Unix/Lnux in fact every system is has server and client software running. And even systems where the main task is e.g. web server or file server (or both) can be text only or still have a GUI. All choice of the owner/system manager.
So when you say it now says “server” and that that means "text-only, I find it confusing, but that is only me :wink: