X64+fglrx+4GB RAM+intel chipset?

Radeon HD 3870 + fglrx + 64 bit linux = crash - Phoronix Forums
black screen with kubuntu 8.04 x86_64 and fglrx 8.5 - Phoronix Forums

Want to seek your opinions on the bug descrived in these links. Basically, users of AMD videocards can’t use fglrx with more than 3GB RAM on intel latest chipsets on 64-bit distros. Black screen and total lockup when trying to start x.
There is something about MTRR tables I can’t quite understand. But nobody is saying what is the cause, what needs to be fixed.

My system is
Core 2 Duo E8200
Gigabyte EX38-DS5
4GB DDR2-1066
ATI Radeon 3870
OpenSuse 11.0 RC1 x64

Hoping for a good solution that doesn’t involve halving my memory or sacrificing performance. Having hardware acceleration would be nice.

It looks like a kernel bug. Your best course of action for OpenSUSE bugs is bugzilla. Search for similar open bugs, and if none exist create one.

Submitting Bug Reports - openSUSE

I know for a fact it is not an opensuse bug.
Tried I think 6 different x64 distros on this machine.

Need help editing the mtrr tables! (fglrx crash) - Phoronix Forums This seems to be the answer. Unsure whether that stays over a reboot though.


GUIDE: How to get fglrx working in Hardy 64 with 4GB of ram or more - Ubuntu Forums or here

Damn Edit button Edit 2

fglrx crashing with large RAM (4GB): How I fixed my MTRR - Rage3D Discussion Area more here plenty on google MTRR tables

I did not say it was an OpenSUSE bug, I said it was a kernel bug. The proper way to report kernel bugs associated with a Novell product is via bugzilla.

this is not opensuse bug nor kernel bug. This is hardware/BIOS limitation. A lot of cheap (desktop) mobos can’t cope with >3GB RAM even though manufacturers claim otherwise. In fact these mobos that will not crash still have exactly the same problem.

You have the following options:
decrease video aperture (BIOS)
decrease video card RAM
use no more than 3GB of RAM
get BIOS update from your mobo manufacturer

even though your problem may go away it is still not fixed and kernel has nothing to do withe the problem.

Wrong again. Windows XP x64 has no problems. Also note that problem appears only on NEW intel chipsets.

He can try to eliminate the fglrx driver:

At the bootsplash type “3”
Boot to runlevel 3
login as root

type “sax2 -m 0=vesa” <–which is a crappy driver, but may get him up
do the config
test ← when it is the way you want

What does that do for you?

I’d get a bug report in; the Devs are good about instructions for finding out what is wrong.

Just to clarify, though, the devs can’t support closed drivers. It’s really an AMD issue, and not a linux/openSUSE issue.

Having said that, they know that there are many users with closed source drivers, so will do what they can to assist. But the onus isn’t on the devs to address the issue.

Just trying to set expectations…



I said, “the Devs are good about instructions for finding out what is wrong.”

Trying to say that they would help isolate the cause of his problems.

And yeah, if it’s the driver, then the bug report needs to be fired off to AMD/ATI. They want to get it fixed too:)