X3270 localhost 3270 spits out can't open display

Hello guys,

I finally managed to emulate hercules under opensuse 12.3, I even managed to IPL it corectly and it actually worked (rather than on Ubuntu).

But i have a problem, I’ve downloaded the x3270 IBM family for terminals, trough this terminal i have to connect to the newly emulated Hercules(mainframe z/os arcitecture). but when I type x3270 localhost 3270 and hit enter it spits out this: can’t open display I’ve read about the error but everything i do still can’t open this terminal, and cannot connect to the emulated mainframe :X please assist!

Ok some update, I managed to open the x3270 by disabling the firewalls (followed https://forums.opensuse.org/english/get-technical-help-here/applications/484537-12-3-cannot-stop-firewall-start-boot.html this guy explanation) but now when I start the hercules, then start the x3270 localhost 3270, the terminal spits out "servname not supported for ai_socktype ?

After you open up x3270 and select connect, then other, what hostname are you using? In some cases you enter your ip address followed by a colon and then the port number such as You might want to check what port number your 3270 devices use in the hercules configuration file. A example of port numbers will be 3270 or some variation of that.

Also check your hercules configuration file to see if there is a name defined to certain 3270 connections. An example of this would be TSO for 3270 based TSo sessions. Similarly console to 3270 console connections. When such names are used you have to add the name in front of the address followed by a ‘@’. So in this case you want to connect to a TSO session so you would use the host name of: tso@

A simple dot ‘.’ shortened my life with hour and 10 minutes but thanks anyway… it worked when I added smpts 465/tcp 465/ucd # Secure then launched not as root x3270 3270 and it worked, yes you are right about the port of the terminal but it is 3270 as default. so it goes directly to the mainframe connection and it is working, so it’s kinda done :slight_smile:

I’ve got another problem tho … when IPLing, after L for IPL then F to point at the device… nothing happens any ideas, advices ?


Ok, you are using secure connections. I have to use different port numbers as I run multiple instances. I don’t bother with secured ports as while its on my own network, it is inaccessible to the Internet. Would be nice to have a PVM setup so as not having to remember port numbers. (Perhaps another project of mine)

(Really should move this to a hercules forum)

After the IPL command you enter an IPL device address. Normally an SYSRES DASD volume address. As it is F is the device address you are trying to IPL from. Which typically “F” is an unusual device address. If you are using the Turnkey setup, try using address 148. If unsure look at the volumes you have and try using one that has a file/volume label of something like SYSRES, MVSRES, or something similar.