x270 ultra dock no sound via headphone jack


I’ve got a lenovo x270 with the ultra dock and have no sound when connecting something to the headphone jack.

From what I’ve read, there are various “model” parameters that help for other lenovo laptops like “tpt460”,“lenovo” or “lenovo-dock”.
However, none of these seem to work with the x270, which I think may also relate to the fact, that it uses an “Realtek ALC298”, which is different from the tpt460. I’ve also looked into the source file, where these model fixes are specified but found none explicitly for the x270.

Does anyone know how to make the sound via headphone jack through the ultra dock work?

Thanks for any advice!

Did you try using pavucontrol to redirect the sound to the headphones???

I’ve tried it with the KDE audio applet, however it reports, that there are no headphones connected.

I’m afraid this is not a routing issue but something that goes deeper (I guess even kernel level), where the appropriate model needs to be defined.

Maybe but try first with pavucontrol. It has more features then the regular volume control

If you provide more information, we can check to see if it is an underlying alsa configuration issue. To provide such information, in a konsole/x-term, as a regular user, with PC connected to the internet, send the following command:


Select the share/upload option, and let the script run to completion. Then look in the konsole/xterm and copy the web-address/url location, where it states it has uploaded the configuration summary, and post that here. We can then check to see if it is an alsa config issue.

Apologies … but ‘none of these’ is a bit vague … did you mean only “tpt460”,“lenovo” or "lenovo-dock ? And please, where is your reference for using tpt460 and lenovo as a model option ? Are these new options for Tumbleweed ? I do not see either in the ALC29x list. I only see “lenovo-dock” in those that you noted you tried.

I’m not on my Tumbleweed PC at present, but in LEAP-42.2 the file listing the options for the ALC29x is the HD-Audio-Models.txt (where I think Tumbleweeds call the file " /urs/src/linux/Documentation/sound/hd-audio/index.rst ". You MUST use an ALC29x option (and not some other). Also just because the ALC29x list does not mention ‘lenovo’ in an option name does not mean there is not a chance it may not work).

Here is the LEAP-42.2 list, and you can check the Tumbleweed list, and I think you will likely find it similar.

ALC22x/23x/25x/269/27x/28x/29x (and vendor-specific ALC3xxx models)
  laptop-amic		Laptops with analog-mic input
  laptop-dmic		Laptops with digital-mic input
  alc269-dmic		Enable ALC269(VA) digital mic workaround
  alc271-dmic		Enable ALC271X digital mic workaround
  inv-dmic		Inverted internal mic workaround
  headset-mic		Indicates a combined headset (headphone+mic) jack
  headset-mode		More comprehensive headset support for ALC269 & co
  headset-mode-no-hp-mic Headset mode support without headphone mic
  lenovo-dock   	Enables docking station I/O for some Lenovos
  hp-gpio-led		GPIO LED support on HP laptops
  dell-headset-multi	Headset jack, which can also be used as mic-in
  dell-headset-dock	Headset jack (without mic-in), and also dock I/O
  alc283-dac-wcaps	Fixups for Chromebook with ALC283
  alc283-sense-combo	Combo jack sensing on ALC283
  tpt440-dock		Pin configs for Lenovo Thinkpad Dock support

Note the above is not to say there is not a problem with the underlying alsa or elsewhere - its only me trying to check that the efforts you made were accurate and optimal (as best I can with my somewhat dated knowledge).

Thanks for all the adivce so far!

I’ve tried the following:

  • install pavucontrols: doesn’t provide me with any new settings
  • uploaded the alsa configuration here
  • I tried lenovo-dock and tpt440-dock. Neither worked.
  • I’ve also tried rerouting with hdajackretask and coudln’t find any working configuration, neither did hdajacksensetest report anything plugged in, when I had audio connected to dock.

I can’t find the file listing the possible model values anywhere though. Could you tell me, if there is an additional package I might need to install?


Did you notice this in the diagnostic script:

**Simple mixer control 'Headphone',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Front Left: Playback 0 **[0%]** -63.50dB] **[off]**
  Front Right: Playback 0 **[0%]** -63.50dB] **[off]**

The headphones are switched OFF. Did you try to switch them on ?

You can do so with alsamixer or amixer.

Try this as a regular user in a konsole/xterm:

amixer -c 1 -- set 'Headphone' on 80%

Possibly I have the syntax wrong , so try this also

amixer -c 1 -- sset 'Headphone' on 80%

Do you get any errors when you try that ?

Note also when testing, pavucontrol may direct the audio to the speakers even IF the headphone volume is not-muted and levels up, so also check the pavucontrol to ensure it is not set to deliberately route audio to the speakers and not to the headphones.

Edit: The amixer command may have the card wrong. Possibly it should be “amixer -c 0” and not “amixer -c 1”.

I gave you that for Tumbleweed in my post. Did you look here: " /usr/src/linux/Documentation/sound/hd-audio/index.rst ".

I may have the card wrong. Possibly it should be:

amixer -c 0 -- set 'Headphone' on 80%

Possibly I have the syntax wrong , so try this also

amixer -c 0 -- sset 'Headphone' on 80%

Do you get any errors when you try that ?

I’ve tried both manually raising headphone volume as well as the following models:

  • laptop-amic
  • laptop-dmic
  • lenovo-dock
  • dell-headset-dock
  • tpt440-dock

I know some of them may be pretty useless in my case but I still wanted to give it a shot. Unfortunately nothing did the trick.

Tried them both ? Do you mean you tried the amixer command with the different “-c 0” and “-c 1” arguments ? Or do you mean you tried “set” and “sset” with the “-c 0” argument ?

Did you not get any errors when you tried any of them ?

This could be bug reporting territory. Note the sound packager for openSUSE is also an alsa sound driver developer for all of GNU/Linux, so any bug raised on openSUSE sound will benefit all GNU/Linux distributions.

Sorry, I meant to say that I tried raising the volume as follows:

**amixer** -c 0 -- set 'Headphone' on 80%
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Front Left: Playback 102 [80%] -12.50dB] [on]
  Front Right: Playback 102 [80%] -12.50dB] [on]

which seems like the right output to me.

And I also tried the various model parameters.
However neither worked.

I do think, that this may be a little more complex, as I saw someone else complain about the same issue with another Kaby Lake thinkpad (T470p) model. I just don’t have any idea how to contirbute to a solution, since I lack any knowledge regarding the sound system.

I also tried messing around with hdajackretask which showed me some unconnected pins but I couldn’t find any working configuration there either.

IMHO the best way to do this is to raise a bug report on openSUSE. That gets the attention of one of, if not the most knowledgeable person in GNU/Linux wrt the underlying alsa driver support. He may - or maynot have a solution - and he may have some test to recommend you try.

There is guidance here on how to raise a bug report: https://en.opensuse.org/openSUSE:Submitting_bug_reports

Raise it against the ‘kernel’ as the sound driver is delivered with the kernel.

You can use your openSUSE forum username and password when logging on to bugzilla.

Attach to the bug report the diagnostic script output from running the command in a konsole/xterm (as regular user) :

/usr/sbin/alsa-info.sh --no-upload

Ensure the bug report is complete. Do NOT bother to reference this thread as the openSUSE / GNU/Linux sound packager/alsa-driver developer will NOT read a forum thread.

After raising the bug report, check it every day or two for a reply from the alsa driver developer. If he asks a question and if you then answer the question, be sure to clear any “NEED INFO” flag.

Edit: If he recommends you try something and you do not know what he means - don’t worry. Just reply and say so. He is very good at teaching here.

Good luck.

Thank you for getting me started on that, I’ll get to it asap!

Filed the bug here.

Thanks again for all the help in this thread! :slight_smile:

hello, try pavucontrol