X1950 Pro AGP Troubles...

Hi all!
I have a radeon x1950 pro agp 512mb, and you probably know what that means… :rolleyes:
so, i need to know how to install the drivers for it. i know other people have had success, but i can’t figure out exactly how. please tell me! i really need to have 3d acceleration on this computer! :frowning:

Please install ATI Repository via YaST.

I already did, but I don’t know what to install. and according to the opensuse wiki, you’re supposed to download drivers before 8.41, but it doesn’t specify where to download them. :rolleyes:
and i also don’t know what parts of that wiki page i’m supposed to use for my system. :confused:

EDIT: it does direct me to the ati driver download page, where i can click “previous versions”. but the previous versions that work for the x1950 pro aren’t compatible with opensuse 11.0. :frowning:


I´m downloading openSuse 11 right now. I run ubuntuStudio Hardy without 3d accelleration. I had 3d accelleration with version 7.10. Hardy died for me as far as the accelleration goes. One thing I noticed about this card and almost all versions of linux. You can´t use AIGLX and desktop effects at all. There is no support from the drivers that are available. I was able to run desktop effects with PCLOS2007 but when tried to play openGL games, it was distorted. So get the desktop effects off your mind and forget about it. You should be able to get 3d accelleration though, Iĺl play around with it and figure it out. It´s been awhile since I did this.


You don’t need to know what to install with the ATI Repo
enabled, just run an online update and Yast will take care
of that. Only thing left to do is to reboot into runlevel 3,
log in as root, run sax2 -r, finish sax and type init 5.