x11vnc causing KDE to crash

I use x11vnc to access my KDE desktop remotely from my work computer using a VNC client. On 11.3 this worked mostly problem-free.

On 11.4 x86_64 I’m finding that KDE is crashing after half an hour to an hour of use. The symptoms are that I suddenly lose the VNC connection. My ssh session also goes at the same time because I use NetworkManager, and of course when KDE crashes it takes the network connection with it. When I get home from work I see that the computer is back at the normal KDM login screen, and uptime shows it hasn’t rebooted.

I run x11vnc in a screen session so I can see any errors it gets, and the only thing relevant is:

31/03/2011 09:41:09 client_set_net: ::1  0.0000
31/03/2011 09:41:09 created   xdamage object: 0x5e0002c
31/03/2011 09:41:12 copy_tiles: allocating first_line at size 41
31/03/2011 09:41:17 created selwin: 0x5e0002d
31/03/2011 09:41:17 called initialize_xfixes()
31/03/2011 09:48:26 idle keyboard:   turning X autorepeat back on.
31/03/2011 10:02:21 active keyboard: turning X autorepeat off.
caught XIO error:
31/03/2011 10:04:12 deleted 40 tile_row polling images.

Anyone have a workaround or tips to using x11vnc with KDE in 11.4?

I am experiencing similar symptoms. I had a very stable build of suse11.4 I have been using for a work application. It had been running perfect for months on several systems. As soon as I installed x11vnc I get random crashes to the log in screen (several per day). As soon as I uninstall x11vnc the crashes stop.

Any work around on this? If this cannot be fixed I will have to switch to Vino (or some other vnc app) and see if that fixes the problem.

OK. So I have isolated the problem to the -forever option. This option keeps vnc running. If this option is not used then I do not seem to have any issues. I really need something that will keep listening for connections after a clients disconnects.

Is there another option to keep x11vnc persistent?

btw sorry for hijacking the thread.

I was having x11vnc problems as well, 11.4x86_64 and KDE 4.7.2
There is an x11vnc update available, seemed to help
See 11.4/KDE4.7.1 VNC crash after recent update - a fix here

It sounds like the Xorg X server is crashing. Could any of you folks look in /var/log/Xorg.0.log and /var/log/Xorg.0.log.old for stack traces or other indications of the failure? Please post them to this thread. x11vnc has ways to work around some of these Xorg bugs.

Hi elf32, thanks for the reply.

I looked in the 2 logs you mentioned, and they are rather large (they seem too large to post the entire contents here). I am not exactly sure what to look for, and do not know what a stack trace would look like. It has information about all of the hardware being used, but I did not see anything that looked like an error.

I look forward to any more instructions, as I would really like this resolved.

Here is an example of one I posted to another linux forum:

Ubuntu Forums - View Single Post - [other] x11vnc shutting down on Intrepid login

If you search on “x11vnc backtrace” at ubuntuforums.org you will find some posts (including from myself) that show how to work around these various Xorg bugs. These are x11vnc options that I believe have been used this way: -noxfixes -noxrecord -noxdamage. I think those are all. Also using a more recent x11vnc version can also help (because it takes steps to delay using those extensions…)