X11 shot after nVIDIA update


I’m having some trouble since my last zypper update yesterday. I’m using openSUSE 13.1, and have kept most everything up to date (run zypper up every few days to make sure I have everything). Yesterday, it happened to have also updated my nVidia drivers. I used the proprietary ones in the NVIDIA repo. Since then, I haven’t been able to boot into Gnome 3. Since I thought it might be the graphics card driver (I have a GeForce 650), I tried reinstalling these drivers (zypper install -f). But that didn’t help.

What I can do is hit ‘e’ in Grub and boot into text only mode (that’s how I reinstalled the drivers). That seems to work just fine. I used zypper there to force update all of my nvidia drivers. When I rebooted though to go back into runlevel 5, I can’t start gnome. Everything looks normal except that instead of the log-in screen I get a white screen with an unhappy computer telling me “sorry, something went wrong.” The only option I have is logging out. See the screenshot here. I click on log out, I just get a blank screen. No other options. I can’t open a virtual terminal either. I rebooted into runlevel 3 to get a copy of dmesg output, but I can’ figure out what to do with it (sorry, don’t really understand how booting works). The output from that file is available here.

Anybody know how I can fix this?

PS: I tried both “recovery” options in the GRUB2 boot menu, neither of them worked.

from what i am seeing your on driver 331.38 and your on geforce 650 so you should be on |304.1170 http://opensuse-community.org/nvidia-gf6_gf7.ymp

but don’t quote me on that but almost sure was same issue i had a few days ago that caused me to have to re install 3 times before i learned what i had done wrong, but if anyone else can add better to this please do, don’t want to be responsible for your system failing or loss of data.|

First, he is using 331.67 AFAICS.

Well, if it really is a GeForce GTX 650, the G03 driver (331.67) is ok, although the G02 one (304.xxx) should work as well.
If it is a GeForce 6500 though, you would be completely right. The G03 driver does not support that card. But in that case he would have had problems already before the update.

Can you boot to “Recovery Mode”? (“Advanced Options” in the boot menu)
This would make things easier, and rule out some other possible causes.

If recovery mode works, please do the following:
Boot normally, until you get the error. Then reboot to “Recovery Mode”.
Then please post the file /var/log/Xorg.0.log, this should give a clue to what’s wrong.

What would maybe also be helpful is the list of installed nvidia and kernel packages:

rpm -qa | egrep "nvidia|kernel"

Oops, sorry. Didn’t notice that you already tried that.
What happened when you tried recovery mode? Did you get the same screen?

Anyway, that Xorg.0.log would be necessary to help you.
Please boot to text mode (run level 3) after a failed boot to get that file.

You might want to change the login manager to something else (xdm should be installed by default) in /etc/sysconfig/displaymanager, and maybe select a different DEFAULT_WM in /etc/sysconfig/windowmanager to get to a graphical system at least.

Thanks for your support!

When I try to boot into recovery mode, I just wind up at the same screen.

Here’s the rpm output, and this is the output from the Xorg file.

yep Xorg.0.log shows its gtx 650 so 331 should be working, my issue i found was after trying to manually create a xorg.conf from nvidia settings, which was working fine for a bit but when i did a update, i tried to remove the xorg.conf file and it for some reason just haulted auto configuration all together, and recovery was not a open (my fault for toying with repos while trying to upgrade).

You have both the G02 and the G03 driver installed. This cannot work!
The packages overwrite each others files, so you can end up with a mixture of both depending in which order the packages get installed.
And that’s exactly what happened in your case now when installing the update. From the Xorg.0.log:

    14.974] (EE) NVIDIA(0): Version mismatch detected between the NVIDIA X driver and the
    14.974] (EE) NVIDIA(0):     NVIDIA GLX module.  X driver version: 331.67; GLX module
    14.974] (EE) NVIDIA(0):     version: 304.119.  Please try reinstalling the NVIDIA
    14.974] (EE) NVIDIA(0):     driver.

Please remove all nvidia packages, and only install the G03 driver.

sudo rpm -e nvidia-gfxG03-kmp-desktop nvidia-gfxG02-kmp-desktop nvidia-glG03 x11-video-nvidiaG02 nvidia-computeG02 nvidia-computeG03 x11-video-nvidiaG03
sudo zypper in nvidia-gfxG03-kmp-desktop nvidia-glG03 nvidia-computeG03 x11-video-nvidiaG03

Or use YaST->Software Management (it has a text mode interface as well). Mark all those packages for uninstallation and select “OK”, then start YaST again and only install the 4 G03 packages.