X11 runs hard when idle

I am not sure if this is the correct spot for this question, but when my computer is idle, X11 runs full out on one of the cores. When resuming from idle then it stops and behaves normally. I had problems with video as well as sound after an upgrade from 10.3 to 11.1, and all seems to be resolved except this issue. I have the nvidia drivers loaded and was only able to get it working after using sax from the command line to get the nvidia drivers loaded (kdm locked the keyboard originally).

My system is setup as follows:

Suse 11.1 X64
Nvidia driver with a GeForce 7300 LE
Screensaver is off now, but power management comes on @ 15 minutes.

I also notice in that when looking at the display settings in KDE it states “Your X server is using the RandR extension at 1.2 or higher with no configuration”. That seems suspicious, but I’m not sure what else would be helpful to diagnose this issue or how to configure it.

Any help would be appreciated.

Can’t tell you much about the first part of your post, except if you’re able to look at core usage your machine isn’t truly idle … or so I would’ve thought

As for showing RandR extension blah in KDE’s display management that’s normal, every nvidia and ati card I’ve ever used shows it

With your nvidia card use the nvidia-settings applet, open it with nvidia-settings as root from a console or look for NVIDIA X Server Settings in System, Configuration on your menu, it should ask for the root password when you open it from the menu

Thanks for the reply.

I can only assume that there is something wrong with X11, because it is running so hard when “idle”. Meaning … if I do not touch the mouse for say 5 minutes or so the CPU starts running at ~50%. Once I move the mouse it stops consuming CPU at that rate.

Very puzzling.

Well I have/had the same issue. I was running 11.1 with compiz, and at idle with the screen saver set to blank screen only I could hear the fan spin up. Catching it by remoting in over ssh I would see it was X using up the resources… Never quite figured it out.

I am using 32bit, 11.1, but also have an Nvidia GPU, running on a Pavilion laptop…

I moved to KDE4, and don’t seem to have the issue there…


Apparently it’s a known bug. There were a whole load of posts about this in another sub-forum recently, but despite my efforts to find them and link them here I cannot now track them down.

It seems to commonly start after around 15 minutes of idle time. On my own laptop I often return after being out the room and it’s running flat out, very noisy and hot, even if the screensaver is basic or blank. This never happened until the 11.1 installation.

I’m using KDE3 with no desktop effects, and no Compiz installed.