X11 only worked with DVI cable but not with VGA cable

I bought a new monitor for my setup under Leap 42.2. The monitor is an Acer K212HQL with a native resolution of 1920 x 1080. I was struggling with this working at resolutions greater than 640 x 480 with the VGA connector being used for input. The machine is a AMD 760G uATX using a NVIDIA GT 630 card and the NVIDIA drivers. Nothing seemed to work until I purchased and installed a DVI-D cable. Once the cable was installed the setup worked just like it should. I had made a monitor entry in the /etc/X11/xconf.conf.d/50-monitor.conf entry as below:

# Having multiple "Monitor" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
Section "Monitor"
  Identifier "Default Monitor"
#  ## If your monitor doesn't support DDC you may override the
#  ## defaults here
  HorizSync 30.0-80.0
  VertRefresh 55.0-75.0
#  ## Add your mode lines here, use e.g the cvt tool
 Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Should the system picked up the DCC entry up with the VGA cable? The modeline looked correct and the cvt command seems to have created a reasonable output with or without the DVI cable in place. While this setup works fine is there a reason it shouldn’t with the VGA cable?

Bob Taylor

In general you can check what is found via DDC by examination of /var/log/Xorg.0.log when connected via VGA. A DVI-D connection will be expected to provide a better quality display than when using an analogue connection of course.