x11 Freezes on Intel i845 Chipset

Hi All,

Oldiesh Laptop, were very slow with all previous versions of suse and even windows…relative high spec though (1gb ram, 1.6ghz Cpu)…anyhow compared suse 11 is flying BUT…now i have trouble with the display , after fresh install (a couple of times) it would simply be very jittery…and then black out…and sometimes come back…but still jittery, tried all kinds of combination’s on resolutions and monitor settings no luck…googled it and somewhere it was said to use vesa…which i did using the xorgconfig …the jittery is gone, but now after about 5min xwindows complete freezes…only way to get out is a hardware reset…so with this knowledge i run xorgconfig again now selecting
the i810 videocard…but the same story…few minutes and all are frozen…doing nothing just logging in!?..

Please help…

Kind regards,


Hi everyone!!
OpenSuSe 11.2 Alpha i810 does not.
Attempt has been extremely week Intel i845 Chipset in sax2 set, sax2 always gives me VESA and not “i810” what really should be
“I’m already on despair” and it is even possible that I’m no linux profit. can give me as soon as possible a help?
sax2-r (VESA) device1 (should actually be Device0)
sax2-r-m 0 = i810 (black screen) crash the X server
sax2-a (black screen) crash the X server

Hi Taruso & welcome!,

Could be you need the Intel driver (should be the default starting openSUSE 10.3). Have you tried:
sax2 -r -m 0=intel

Also have a look at this thread (mainly post 18 and further) : OpenSuSE 11 and Xorg update - openSUSE Forums

Could be you need to set the options:
Option “XAANoOffscreenPixmaps” “true”
Option “DRI” “true”
Option “AccelMethod” “Xaa”

Wishing you luck,

If you had success with a previous version of x, you might want to boot into a liveCD of one of those old ones that worked and save a copy of your xorg.conf, then just drop that one in. This has worked for me in the past.