X11 does not work properly after todays Nvidia 525.85.05 upgrade

Today Nvidia drivers were updated to 525.85.05 with zypper dup. After restart X11 shows just mouse cursor with kernel 6.1.6, with 6.1.4 it shows sddm login screen, however after login it restarts X-server - so can’t start session.

How to fix?

Could be driver update issue.

TW 20230118 / nvidia-G06 525.85.05 driver: sddm dumps core - openSUSE Factory - openSUSE Mailing Lists

Yes, thanks, fixed:

this worked aswell:

sudo zypper in -f nvidia-video-G06 nvidia-driver-G06-kmp-default


I’m on a Razer Blade 2019 with rtx 2060. I had to revert back to G05 drivers to get my card working again. it seems the G06 has some issue with the optimus enabled laptops for some reason. I never had this issue till this update. Unfortunately, now this restored my previous issue with G05 and steam proton games/apps not launching. Some either launch and have black screens, or crash to desktop. Very frustrating because not even my external monitor works on g06. When installing the open GL packages and using prime-select, I get the black screen with mouse cursor as well.

This topic is about issue on G06 driver update. Start new topic with clear subject that describes your problem.

Yes. I know. I was on G06 (because ot fixed my proton issues with G05) and then the update broke my graphics. I had to revert to G05. Reinstalling G06 did not fix. It caused the same black screen cursor issue as above. Maybe my post wasn’t clear enough. G06 is bork with my optimus gpu laptop.

Where is an option to mark a message as a solution for this topic?!

Add “Solved” plugin - English / Forums Feedback - openSUSE Forums

I think forum admins should do this!!!