X won't start after AMD Catalyst Driver Install

I have installed Tumbleweed off and on over the last 6 months. Overall I have been very pleased with every aspect of it, except one: AMD Proprietary Drivers. On openSUSE’s Software Portal, there are three ways to install the driver: 1) using the “One-click” install method, 2) Using a script that downloads and installs the driver, or 3) Downloading, compiling, and installing the driver manually. This is where the problem comes in.

Each of these three methods have been tried, but it always ends up with X not starting. I’ve also tried to initiate a default xorg.conf configuration file using the “aticonfig --initial” command. Still no dice, although I do get a bit more information after trying that. It seems that it is not matching the correct PCI ID to the proper hardware. I can tell this by using the “lspci” command and comparing the ID for my driver with the what is listed in the xorg.conf file. If I use another tty and try to start X manually, I get the error that a display device can not be found.

After attempting to install Tumbleweed over the past few months several times to see if anything would change (bug fixes, etc), I’m still left with the same situation.

I really want to keep openSUSE Tumbleweed as my distro of choice but I feel I shouldn’t have to sacrifice the performance the proprietary driver gives me in able to do so. Perhaps there is a solution to all this on the forum, but I have yet to locate it. Any help with this would be GREATLY APPRECIATED. Thanks!

It would be worth to see your

# lspci |  grep 'VGA\|ATI\|3D'

and Xorg.0.log (corresponding to xorg.conf produced with aticonfig --initial -f).

If you’re referring to the bus:slot.function value listed by lspci for the device, and if that value is wrong under the BusID value for the Device section of the xorg.conf file, then simply change the xorg.conf value to match that given by lspci. However, note that lspci lists in hex, whereas the xorg file uses decimal … in any regard, I really doubt this is the problem, unless the xorg.conf you’re using is recycled from some other config.

If I use another tty and try to start X manually, I get the error that a display device can not be found.
by default, you can not startx as user in openSUSE


I will attempt to do that, but last time I installed the proprietary driver I was left with the CLI to interact with which means I would have to use Links web browser to post my results.

Is this a notebook with hybrid Intel+AMD GPU.

You should be able to boot to some graphics (maybe not Gnome) if you select advanced and recover mode mode at the grub boot menu Since it will boot to fall back drivers