X window problem with kernel on Dell Studio 15

I was unable to run X window after updating from the “old” pae kernel to the “new” on my Dell Studio 15 laptop with openSUSE-11.1 (32-bit). The laptop has ATI Radeon 3450 graphics and was running the proprietary ATI 9.2 driver prior to the installation (custom compilation). Installed as part of that is the custom built fglrx_7_4_0_SUSE111-8.582-1 rpm (which may be the problem as I did not remove it).

When I rebooted after the kernel update, X took me to a broken screen, as expected (mostly black but bottom 1/3 was full of purple horizontal lines).

Neither <CTRL><ALT><Fx> nor <CTR><ALT><Backspace> had any effect. <CTRL><ALT><Delete> a few times resulted in a reboot.

At the reboot I pressed “3” at grub menu, and hence booted to run level 3, logging in there as a regular user.

From run level 3, none of the following worked (all resulting in a black screen with purple lines at the bottom):
sax2 -r -m 0=radeonhd
sax2 -r -m 0=radeon
sax2 -r -m 0=vesa
Also, all of them resulted in a segmentation fault just before the ugly screen:
sh: line 1: 8278 Segmentation fault /usr/sbin/acpidump 2> /dev/null
sh: line 1: 8335 Segmentation fault /usr/sbin/acpidump 2> /dev/null
sh: line 1: 8339 Segmentation fault /usr/sbin/acpidump 2> /dev/null
sh: line 1: 8343 Segmentation fault /usr/sbin/acpidump 2> /dev/null
The above scrolled by so fast I had to capture them with a digital video camera. Each required a <CTR><ALT><Delete> reboot.

Its possible removing the fglrx_7_4_0_SUSE111-8.582-1 rpm and then trying the above openGL/vesa sax2 commands again will work. Its also possible if I re-install the ATI proprietary 9.2 driver (or install the newer ATI proprietary 9.3 driver) will also solve the problem (after a “sax2 -r -m 0=fglrx” ) .

As it was, since I installed the new kernel with "rpm -ivh kernel- … etc … " I simply restored the orginal xorg.conf file (that I had backed up prior to my attempts) and rebooted back to the old kernel (as my grub menu gives me multiple selections).

So no dramas. The old kernel works well and I have my X window running with the ATI proprietary driver.

But I’m puzzled that neither the openGL nor vesa drivers would work with the new kernel and the Radeon 3450 on this laptop. Is it the fglrx_7_4_0_SUSE111-8.582-1 rpm that is causing this? Or am I missing something fundamental (and making newbie mistakes) ?

I could try and configure the vesa/openGL driver with the kernel as a test, but before I start messing about, I thought I would tap into the knowledge on our forum. What am I missing?

I do not normally use proprietary ATI drivers, and its quite possible this is a simple lack of experience on my part (and switching back to openGL or vesa is not so easy). ??

I’m having a similar problem. except x wont come up at all. boots to command prompt only, sax gives a similar result as your system. I was hoping someone had figured it out by now and had a solution. :frowning:

running a Core 2 Quad CPU Q6600 @ 2.40GHz with a GeForce 8600

Presumably this is NOT on a Dell Studio 15 laptop. :slight_smile:

You could do what I did as an interim, which is to roll back to the older kernel version (in my case, I installed the new and kept the old installed so I could dual boot to either - hence for me, no roll back needed although I did change the default boot in grub from the kernel to the kernel). Then restore the old xorg.conf file like I did (ie the file that was in use before the failed sax2 attempts). Presumably you have backups so this is no problem?

When you say same problem (with a nVidia card), did you try these nvidia sax2 options:
sax2 -r -m 0=nvidia
sax2 -r -m 0=nv
sax2 -r -m 0=vesa

I also rolled sax2 back from the sax2-8.1-542.8.1 version to the older sax2-8.1-542.7 version to see if that made any difference. It did not.

that was the first thing i did :slight_smile:

seems to the the kernel that is the cause as i tried the earlier nvidia driver with the same problem. curiously, no one else is having the same problem… which makes me wonder what we are doing wrong!

or is it that we are doing right and everyone else is, and the problem only shows up when it is doen right? :stuck_out_tongue:

ok i’ve noticed that yast isnt locking updates at all. so in last update i did i left it in. system is working fine…

i hope you have resolved your troubles.

i’m not sure what i did to correct things on my system.

might have been my ernest angely impression… where i slapped my open palm to my monitor ans shout “HEAL! CAST OUT YE EVILE CODE! YEAYA!”

IBM T60 laptop with ATI radeon mobility x1400 with new update have the same problem. So, I rolled back the kernel to but I am having the same issue.
Any clue?

saX2 complaining about : /usr/sbin/xw: symbol lookup error: /usr/lib64/xorg/modules/updates//extensions/libdri.so: undefined symbol: atiddxMiscDixLookupPrivate

No idea.

I have not tried again since, and I’m still using the kernel.

I note AdmiralFubar had Nvidia graphics, and not ATI, and hence I do NOT think his was the same problem.

Hello oldcpu,
thanks for the descriptive post. I am having similar problems with the same device.I did not managed to find the stable combination yet. Could you also post how do initiate the drivers? Are you using “aticonfig --initial -f” or just “sax2 -r -m 0=fglrx”?

I’m not sure what you are attempting.

In my case, when my Dell Studio 15 had the, I noted there was a kernel available from Novell/SuSE-GmbH. So I made a backup of my /etc/X11/xorg.conf file and the /boot/grub/menu.lst (in fact I already had backups of both). I downloaded the various new kernel applications to my hard drive (I did NOT install them via zypper nor via smart). I then removed the kernel-source and kernel-syms but I kept the remainder of the kernel rpms installed. Then with root permssions I installed the many kernel packages with the “rpm -ivh” command with something like: “rpm -ivh kernel1-app.version.rpm kernel2-app.version.rpm kernel3-app.version.rpm kernel-source.version.rpm kernel-syms.version.rpm” where “kernelx-app.version” should be changed to the name of the new kernel.

By doing that, the /boot/grub/menu.lst file was modified to allow a dual boot between the new kernel and the old kernel, but all the support packages (kernel-source and kernel-syms) were for the new kernel. I then rebooted to the new kernel in run level 3, and tried “sax2 -r -m 0=radeonhd” (which should load the openGL driver but it failed) and “sax2 -r -m 0=radeon” and I tried “sax2 -r -m 0=vesa” (which also failed). I did not try to rebuild the proprietary driver (that may have worked).

Instead, I simply restored my backup /etc/X11/xorg.conf file and rebooted to the old kernel (which was (still is) a grub boot option) and I booted successfully to X. I did go and change the default boot from the to the And so now I simply boot to the with the proprietary ATI driver.

I made no reference in my post to “aticonfig --initial -f” nor to “sax2 -r -m 0=fglrx”, because I did not try those with the kernel. I did use the “sax2 -r -m 0=fglrx” when I first built and installed the proprietary driver for kernel, but with the kernel, I wanted to prove the openGL and VESA driver worked before trying the proprietary. They did NOT work, and so I stopped.

Note if a build of the proprietary ATI radeon driver with the kernel fails, then that will “break” my ability to boot to the kernel with the proprietary ATI driver. So there is a risk there. It will require I rebuild the driver for the kernel. Now I try to avoid risks.

And I have not touched that for some weeks (as many other priorities have come up in my life). Possibly sometime, I may try again, as there are many things I did not try.

Not sure if that answers your question?

I had the same problem. ATI graphic, and X that would not work after upgrade to kernel.

I was able to fix it by removing the ATI driver packages, rebooting and running “sax2 -r”.

I removed:

  • ati-fglrxG01-kmp-default|8.582_2.6.27.19_3.2-2.1
  • x11-video-fglrxG01

I also removed the ATI repository to keep the SUSE drivers.

My graphics card is on the motherboard and sax2 -p returns
Chip: 0 is -> ATI ATI Radeon HD 3200 Graphics 01:05:0 0x1002 0x9610 AGP radeonhd

I still have installed:

  • xorg-x11-driver-video-radeonhd-1.2.4_121202_4e89726-2.1.1