X window fail from cold boot

I’m running openSUSE11.0 on my IBM Thinkpad T22 (Yes really). The initial install has been fine, but since an update about 2 weeks ago X windows has locked the machine from a cold boot. On holding down the power button and re-booting the system starts fine.

How do I know it’s X windows…
Well I assume it’s X Windows because the screen goes black and the cursor appears in the top left of the screen for a second just before the X appears in the middle of the screen. When it locks up the X never appears.

How do I know it was an update and not something else I did…
I have two boot options - One from a USB key and another from the harddisk. (Getting the USB key working from boot after a number of modules were changed in an earlier kernel update was a nightmare but anyway…) The updaters on each boot option work separately. I first noticed the problem on the USB which is my main boot option. It wasn’t until I had booted from harddisk deliberately allowed that also to be updated that I noticed the problem was repeated.

I am at a complete loss as to how to fix this.


I don’t understand your description of the problem. It reads like you have a work around?

Still, if you are convinced your problem is a work around, why not narrow this down to the offending package, and then roll back to an earlier version? To obtain a chronological list of rpms that you installed type in a konsole / gnome-terminal:
rpm -qa --last > installed-rpms.txt
and then with a text editor open up “installed-rpms.txt” and look for the date in which this problem occured, and pick out the offending rpm. Please do NOT post the text file here, as it would be too long. If you are insistent on sharing part of the file output, you can post ONLY the relevant date contents on general pastebin - simplified internet collaboration , submit it, and post the output URL you are provided here.

This sort of problem should not nominally happen with an update, and it makes me wonder if your repositories are setup inappropriately. Can you also type in a konsole / gnome-terminal:
zypper lr
and copy the output to general pastebin - simplified internet collaboration , submit it, and post the output URL you are provided here. IMHO you should ONLY have oss, non-oss, update and packman repos selected. Any others will just lead to trouble, especially if you do not understand the implications of adding additional repos.

Yes I do have a work around but it is not satisfactory; that is to hold the power key for 10 seconds to power off then machine and then immediately power back on again and repeat the boot process.

Thanks for the pointer on the install history I’ve not doubt it will be useful again in the future. This time however it turned out that there were about 60 packages all installed at the same time. I tried rolling back various X servers and drivers, power management and kernels but to no avail - And each test requires the machine to be stood for 5 minutes to be sure the fault would show if it still existed, so the process of repeating each test twice is very time consuming.

I started watching messages more clesly just before the hand, and looking at boot.msg and boot.omsg after each failure (boot.omsg always containing the failed boot log). You can see examples of these at Index of /bootlog. From these I noticed the variation in starting sequence of kdm, powersaved, CPU microcode and other modules that start at typically the same time.

So I now have an acceptable work around. Sadly it doesn’t help find the problem but I suspect the problem may have been around for a while and the serendipity of timing has exposed the problem. Oh, the work around is to disable earlyxdm.

If you want me to try anything I’d be happy to give it a go; I’m still muchly confused as to why this makes the problem go away - earlyxdm was the only service in rc5 with a start number of S04. Has the init process manager (what do you call it) been changed causing things to start out-of-sequence?


60 packages is very unusual.

Either you went for a very long time in between updates, or you may have too many servers in your repository list.

I recommend you ONLY keep OSS, NON-OSS, Update and Packman. No others. None. If you believe you need another repository for a specific package, then you can add thje other repos on a temporary basis, install the app you want, and immediately remove the repository.

Too many repositories can cause a user all sorts of difficult to track down problems.

Gah!, just when I post to say it’s OK it goes wrong.

Yes 60 packages or more. The install dates go 10th June (which I believe will be the DVD build date), then 1st August. I did a fresh install trying to get my USB key to work after the kernel upgrade. I only have the main repos, updates & packman (& videolan). I’ve not installed a lot of software.

I’ll have a guess that it’s now failing because I’m not watching the init logs scroll by but will have wait to confirm my theory.

Any other ideas would be appreciated but otherwise I’ll just keep posting updates should anyone else find this at all useful.