x server won't start

Made the horrible mistake to try and install catalyst from the ati website (ati-driver-installer-9-6-x86.x86_64.run). Stupid idea. Now x-server won’t start. I can get to the prompt on session 1 and runlevel 5 is reached, but only get a black screen. Is there a way to roll back to previous config? “SaX2 -r -m 0=fglrx” hangs the machine (can’t go back to session 1)

preliminary info:

opensuse 11.1
ati radeon 4850

more info?

Thanks in advance for any help.

You might be able to boot to the desktop with the failsafe boot from the menu.

Otherwise boot to level 3 - login - switch to su and use the vesa switch:

sax2 -r -m 0=vesa

re boot

Already tried booting failsafe but that didn’t work.

Thanks for the vesa suggestion. I will try that when I get home.

How do I uninstall the catalyst driver then and revert back to the fglrx which worked prior the ati catalyst?

Is this what you did:

** Manual driver installation **

Since ATI driver release 8.16.20 the ATI installer needs to be used
to create SUSE/Novell RPMs. Download the ATI installer from the ATI

Advanced Micro Devices Inc. → Support & Drivers → Download graphics drivers

It is possible to create RPMs for the following SUSE/Novell distros.
This information has been retrieved by using the installer itself:

./ati-driver-installer-8-12-x86.x86_64.run --listpkg

SuSE Packages:
SuSE/SUSE103-IA32 (openSUSE 10.3-IA32)
SuSE/SUSE110-IA32 (openSUSE 11.0-IA32)
SuSE/SUSE111-IA32 (openSUSE 11.0-IA32)
SuSE/SUSE103-AMD64 (openSUSE 10.3-AMD64)
SuSE/SUSE110-AMD64 (openSUSE 11.1-AMD64)
SuSE/SUSE111-AMD64 (openSUSE 11.1-AMD64)


Create a RPM for SUSE 11.1 (AMD64) by using the installer.

./ati-driver-installer-8-12-x86.x86_64.run --buildpkg SuSE/SUSE111-AMD64

Afterwards install the created RPM by using the rpm command. In the
mentioned example above this would be:

rpm -Uhv fglrx64_7_4_0_SUSE111-8.561-1.x86_64.rpm

The postinstall script of this RPM will try to compile the required
kernel module. If this fails, you’ll get a message how to proceed.

You still need to configure the driver with SaX2. Details can be found
in /usr/share/doc/packages/fglrx/README.SuSE.

Unfortunately you need to recompile the “fglrx” kernel module right
after any kernel (security) update. Use “fglrx-kernel-build.sh” for

No, unfrotunately not.

I simply ran the *.run file and followed the instructions on the graphical installer which came up.

I suppose that now Yast doesn’t know about the new driver. Ouch!

What were you using before.

You can login to level 3 and then go su and start Yast with: yast

It’s keyboard navigation
re-install the kernel see if that helps

*to get to level 3 just type 3
in the boot line arguments

I was using fglrx from the 1-click install on the opensuse ati page.

You can login to level 3 and then go su and start Yast with: yast

It’s keyboard navigation
re-install the kernel see if that helps

Is that the linux kernel or is there only one kernel? (kernel-default in yast software management)

kernel-default if that’s the one you have, just look for kernel in software management. You should be able to mark it to re-install
If you have the ati repo in there, why not re-install that too.

No luck with reinstalling kernell and ati driver.

Also tried 0=vesa in sax2 but all I got was a sax prompt.

Any other ideas beside reinstall?

Yes. Roll back the kernel.
Do what you did before but in the window use the versions tab to select the radio button down to get an older kernel and try also reinstalling the ati driver from the ati repo you have

I don’t see how to select the version to install in the console mode of yast. The only actions are Install, Delete, Update, Taboo, and Lock.

Give me some time. I’ll have to reboot my machine to try it for you.

I don’t if that helps, but at the end of the boot messages, it says

Skipped services in runlevel 5: vboxadd vboxvfs

A little higher it also says that (modprobe vboxadd failed) and (modprobe vboxvfs failed).

I couldn’t see a version tab either.
The error you report is to do with Virtual Box, you probably will need to run the driver setup for it when you get thru this.

Thing is the vesa switch should work. Try it again. Boot to level 3 - login and then go su and do:

sax2 -r -m 0=vesa

When you reboot if it fails - try startx at the cli
If that fails, try switching to su and do: sax2 -r

In the instruction I just read it says:

If the ATI Proprietary Linux Driver was installed using either the Automatic or Custom
options, then do the following:

Launch the Terminal Application/Window and navigate to the /usr/share/ati folder.

With superuser permissions, enter the command “sh ./fglrx-uninstall.sh”.
Reboot your system.

You have now successfully uninstalled the ATI Linux Proprietary Driver.

sax2 -r -m 0=vesa just gives me the vesa prompt.

startx now hangs the screen (with a garbled display). Hitting Ctrl-Alt-F1 throws me to a white screen and hangs the machine.

sax2 -r also hangs the screen on a black screen.

In yast software management, I found x11-video-fglrxG01 (searching for the string " ati ", and ati-fglrxG01-kmp-default (and -debug, -pae, -trace). Only debug is installed.

So maybe check on the earlier info I gave about uninstalling.

Then go back to yast and make sure you have the x11-video and the kernel driver

I’m not sure if you should be using 01 or 02 versions, hang on I see if I can check.

Ok, I followed the instruction to uninstall the proprietary driver and the machine now boots to the prompt (without specifying runlevel 3). sax2 won’t start with the message

xc: sorry could not start configuration server
xc: for details refer to the log file:


xc: abort

That log file is very long but one of the last paragraphs complains about unloadable fglrx module (loading instead kdb).

Check this page: ATI Radeon Xpress - openSUSE

I don’t even use ATI myself so sorry if I’m a bit flaky. Is yours radeon express?

So would the solution now be to go back to yast and use the repo to install the driver you had before you crashed it.