x server start fails

on boot I got a message that (part of) level 5 was skipped, and I ended up on console. So I tried startx but get this message (probably the reason boot failed also):

xauth: file /home/kostas/.serverauth.3396 does not exist

Fatal server error:
Cannot move old log file “/var/log/Xorg.0.log” to “/var/log/Xorg.0.log.old”

Please consult the The X.Org Foundation support
at X.Org Wiki - Home
for help.

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

xinit failed. /usr/bin/Xorg is not setuid, maybe that’s the reason?
If so either use a display manager (strongly recommended) or adjust /etc/permissions.local

googling on “.serverauth does not exist” I tried reinstalling kdm, but nothing.

googling on “Cannot move old log file …” I treid to suid /usr/X11R6/bin/Xorg" but it doesn’t exist, in fact /usr/X11R6/bin/ is empty! (have I lost X11?)

Any ideas?


From 11.4 release notes:

The setuid bit on /usr/bin/Xorg is needed for starting X as an unprivileged user, e.g., via startx. This method has been deprecated for years in favor of using a display manager. Modern environments rely on device ACLs and polkit privileges, which in turn depend upon consolekit tracking the active console, which is performed by the display manager.

Users who depend on the old configuration can set the setuid bit themselves in /etc/permissions.local by removing the comment sign from the following line:

#/usr/bin/Xorg                 root:root       4711

and running SuSEconfig --module permissions afterwards.

This answers your question about startx. You might have another problem though.

Xorg is in /usr/bin:

 find /usr/bin -name "Xorg" -ls

and is in pakage xorg-x11-server

 rpm -qa | grep 'xorg-x11-server'

Thanks, please_try_again. I was able to set suid finally, but it would still not start. doing a zypper up I saw that a lot of X11 stuff was available, so I tried upgrading. The system still does not start X on startup, but doing it by hand I got a black screen (that’s progress, right?). no other terminals (ctrl-alt-f2 and so on) are accessible, and I can’t ctrl-alt-backspace either, but I can ssh. so here’s the current Xorg.0.log: 72.089] X.Org X Server 1.9.3 Release Date: 2010-12-13 72.089] X Pr - Pastebin.com](http://pastebin.com/JkbHHAxz)

Could the problem be (line 293) “The PCI device 0x10de06e4 (GeForce 8400 GS) at 01@00:00:0 has a kernel module claiming it.”?

Any help appreciated.

Yes, this is the problem. Why don’t you install the nvidia proprietary driver? It will probably solve the issue. You’ll need an Internet connection in console mode though. If you have it, just type:

su -l
zypper ar http://download.nvidia.com/opensuse/11.4/ nvidia
zypper refresh
zypper in x11-video-nvidiaG02

In the end the package was already installed. But in xorg.conf the driver selected was nv not nvidia (Probably some update had changed the conf file). Putting nvidia back in, and startx works all right. Haven’t tried reboot yet. Anyway, seems solved. Thanks for the support please_try_again!

There are other things that must cause this. I just had my solid state drive go bad. I changed /tmp from sda7 to sdf1 and I am getting the same error. I CAN log in as root via startx, so it must be a permissions thing, but not sure what. I seems related to /tmp for me though.

I don’t know, but in any case, after changing the location of /tmp, I would do that:

su -c 'chmod 1777 /tmp'

And also make sure that /tmp is mounted.

Notice that in some cases, it might be a problem to have /tmp in a separate partition. If it is not on the same fislesystem as /var/lib, xkb might fail to recompile the keymap for the client (cross-linking error). This causes keyboard problem while accessing an X server remotely. That’s why I usually ceate a separate /var partition and a /tmp symlink of /var/tmp (so /tmp and /var/lib are on the same partition).

Hello everyone

I have the same problem as you, but mine was a little different. The error was 1249. The messege: /home/akihisa/.serverauth.1249 does not exist.
Please ask for help at wiki x.org. I use Fedora 16, and checked /etc/permissions.local file, but there was not. I need your help.
Many thanks