X Server crashes with Nvidia drivers

Hello, I’ve been attempting to get to the bottom of this issue for the past few months, without much luck. I’m currently running 11.3 64-bit (the issue also existed in my previous 11.2 64-bit install) and whenever my laptop is unplugged, the X server will intermittently crash. This issue can be provoked by running Flash applications like YouTube but the same issue will also occur by simply navigating the desktop.

The messages log reports the following:

X server for display :0 terminated unexpectedly

The laptop is an Alienware M15x with an Nvidia GTX 260M.

I initially suspected that this was some sort of an ACPI issue so I tried disabling ACPI for the Nvidia card via the “ConnectToAcpid” xorg option. This did not make any difference so I went as far as shutting down the acpid service. This also did not make any difference.

As a quick test, I uninstalled the proprietary Nvidia drivers and that seemed to resolve the issue but given the limited functionality of the OSS driver, this is not a suitable workaround. Keep in mind, I did not run under the OSS driver for very long so this result could be just a false positive.

Any input would be greatly appreciated.

Thanks very much.

Quick update. I was able to reproduce this failure when running under an IceWM session. This being the case, I don’t believe that it directly relates to KDE. Just a guess though.

(i’m not a real guru, but) i guess you need to grit your teeth and run
with the non-nVidia driver long enough to assure yourself that the
problem most likely lies within the non-open source driver…and, then
file a bug with all the details you can muster…

i do not know exactly where to file the bug, but i’d begin searching
for the correct place at nvidia.com

alternatively: maybe it is a specific mismatch between openSUSE and
your nVidia card with the driver…i don’t think that likely, but you
could rule that out by booting a non-openSUSE Live CD which packs the
non-open driver (i think Mint/Mandrivia/or one of those kinds
‘taint’ out of the box)…if something like runs without error, that
might prove it is an openSUSE problem, then you could begin here:
http://wiki.opensuse.org/Submitting_Bug_Reports
(and, maybe you should anyway, i do not know! hopefully/maybe others
will look and in and give better advice!!)

oh wait! re-reading your posts, i see you write “whenever my laptop is
unplugged” which may be the clue which points to a hardware or other
problem: for example, have you adjusted your power-saver profiles to
automatically switch to energy savings when not plugged in? what else
did you change in the not-plugged-in profile? if so, force the machine
to ‘full’ speed performance while not plugged in…does X using the
nVidia driver still crash? (yes, i know you want to save battery, but
you also want to find the root problem, right?)


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

Thanks for the reply.

I seem to recall mirroring my unplugged profile to match that of the plugged-in profile earlier in troubleshooting this issue ( when I was messing with ACPI ) and it didn’t make a difference. However, that being said, I’ve tried so many different subtle configuration changes to see if it makes any difference, I’m willing to give it another shot tonight.

Depending on the results of the power profile test, I’ll proceed to revert back to an open source driver and/or test against a live disk and then go from there.

Thanks again.

x2012x wrote:
>
> then go from there.

good luck!


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

Good news to report, thus far. After much more process of elimination, I can safely say this issue relates to functionality provided by the proprietary Nvidia drivers.

Also, after even more research and testing, I think that I may have isolated the root cause. This seems to relate to Nvidia’s “PowerMizer” functionality. By default, the PowerMizer Preferred Mode is set to Adaptive. After switching this setting to “Prefer Maximum Performance” I have not yet been able to reproduce the X server crash. I’ve switched back and forth between these settings numerous times and I can easily reproduce the crash but ONLY when unplugged AND running under Nvidia’s PowerMizer “Adaptive” mode.

So, I’ll continue to run under the “Prefer Maximum Performance” setting for the next few days and assuming the issue still doesn’t surface, I think it is safe to say that the setting change is a good enough workaround (for me at least) and I’ll proceed to file a bug report with Nvidia ( and potentially OpenSuSE just for additional exposure ).

I’ll update the thread in a few days with the final results.

Thanks

Thanks for sharing the results of your investigations.

There is also a nVidia forum where all distributions join to explore issues, and you may find that a useful place to post your discoveries, if you have time: NVIDIA Linux - nV News Forums

good on you x2012 and oldcpu!!


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

I have a similar problem on my Ubuntu with a Nvidia driver.
At some point it just froze up, i managed to restart the computer but I am no X server expert so I have no idea how to fix it.
Now the graphics wont even start at all. All I can do is to use the command line. I tried to run X then but it would not work. It would freeze up with no possible way (that i know of) to escape but to use power button.

Is it possible to even fix from command line? I am a newb at linux, so i know very little about how to fix such things, so must i reinstall the whole ubuntu (which formats hdd) ?

Once in the command line, you can shut down (even in Ubuntu) by typing:

shutdown -h now 

or restart with

shutdown -r now 

It is possible in openSUSE. But its difficult for a newb. I suspect it is also difficult for a newb in Ubuntu.

It depends on a few things … such as how do you access the internet? Via a wired connection ? If via a wired connection then you likely have internet access at this text mode (we call it run level 3) and you can download and install the nVidia drivers from that text mode.

Its been so long since I used a debian based system, that it is not something I can rattle off the top of my head (in terms of the EXACT Ubuntu/debian command). For me because I use openSUSE all the time, it is easy for me to come up with the openSUSE commands. But we have a number of Ubuntu users on our forum (who also use openSUSE) and I hope one of them chime in to you give the Ubuntu help you need.

… of course, you could just install openSUSE :smiley:

Interesting. I’ll also try setting “Maximum Performance” as the preferred setting.
In the meantime if you crash again, would be interested if you see the same error I’m seeing… Although somehow you were able to capture the error message saying the xserver terminated unexpectedly, when I do the following I actually get an error message saying that the xserver on instance 0 is still running and cannot therefor be started…

CTL-ALT-F4 This should cause you to logout of the current session and display a login prompt
Logon as any User other than the original User (logging in as the original user apparently returns you to the same crashed session), root is sufficient.
startx This should display the error I describe where the xserver is actually thought to be running.

I’ve seen this often when playing a game played in full screen svga Graphics mode, when exiting the game the xserver seems to have problems returning to my WSXGA+ mode.