X server configuration question

some time ago i tried to install the legacy catalyst driver for my amd card,however at that time the legacy version of catalyst didn’t support suse 12.3 and refused to install,leaving only a log file saying my distribution wasn’t supported, now i’m on 13.1 using the open source driver, but when i check /var/log/Xorg.0.log i see it tries to load the catalyst (fglrx) driver first:

37.893] (==) Matched fglrx as autoconfigured driver 0
37.893] (==) Matched ati as autoconfigured driver 1
37.893] (==) Matched fglrx as autoconfigured driver 2
37.893] (==) Matched ati as autoconfigured driver 3
37.893] (==) Matched modesetting as autoconfigured driver 4
37.893] (==) Matched fbdev as autoconfigured driver 5
37.893] (==) Matched vesa as autoconfigured driver 6
37.893] (==) Assigned the driver to the xf86ConfigLayout
37.893] (II) LoadModule: "fglrx"
37.894] (WW) Warning, couldn't open module fglrx
37.894] (II) UnloadModule: "fglrx"
37.894] (II) Unloading fglrx
37.894] (EE) Failed to load module "fglrx" (module does not exist, 0)
37.894] (II) LoadModule: "ati"

i tried to search the config files in /etc/X11/xorg.conf.d/ to change the loading sequence with no luck, i don’t have a /etc/X11/xorg.conf file
i’m wondering why it tries to load fglrx if it didn’t even install.
i want to find out how to change the order of the loaded drivers,maybe catalyst changed the config even before being installed… if so are there other things i need to fix from the attempted installation?
any help appreciated

it is usefully function on forum ‘search’ :)try look at this, all what you need to run AMD ‘fglrx’ driver’

Czeslaw M.

i don’t want to run fglrx anymore, just trying to fix X config to load the proper driver by default
from the links you provided and some reading i figured i might need to edit 50-device.conf

Identifier “Default Device”

#Driver “radeon”

so will uncommenting these two lines do the trick? is “default device” a good identifier?

You are not using fglrx since it is not installed.
You don’t have to change anything, that’s just X’s auto-configuration. It tries to load a few drivers for your graphics card and then use the best one.
That’s normal.