X Selection Mechan. (Copy&Paste) does not work with SuSE11.1

I installed SuSE 11.1 and realized that the X-selection mechanism did not work properly.
It is not possible to reliably copy & paste text strings between 2 konsole (e.g. xterm) windows. Sometimes it works, mostly not. Cannot find a rule when it works and when not.
It makes no difference how the text is copied (by double-clicking with left mouse button or highlighting with pressed left mouse button); the paste with middle-mouse button does mostly not work.
Has anybody made the same experience or does someone know a remedy.

Have you tried using shift|insert to paste?

Do you mean holding the Shift button while pasting with middle mouse button - I did not try it.

My problem is that I cannot check it, because I replaced my system by Suse 10.3 which formerly worked with no problems.

I tried also the current Ubuntu (10-08) where I had problems with 3D/Mesa (which I need).
So I tried SuSE 11.1 again but with Gnome where the X-selection problem seems to be better at first. But it worked also not reliable. Nevertheless, I feeled it worked better than with KDE.
After multiple boot operations the system got more and more boot problems until it totally stucks during boot.

So I reinstalled my old 10.3…
Installing Linux is not always easy.

under KDE4 I always disable to clipboard utility in the tray, forgot what it is called.
As I don’t need a utility to handle my clipboard, I simply expect the last thing I copied or cut to be available under paste.

Don’t know if gnome offers something similar by default.

Do you mean klipper?
I suspected this application which was running in the panel by default. So I closed it, but the problem continued.
Nevertheless with Gnome it also did not work properly.