X or Wayland

Which is better for a simple desktop? I usually run Kde but I don’t even know how to run it with Wayland

On my last test, Wayland finally seems to be running pretty well for KDE (on Tumbleweed). This was after the update to Plasma 17.2.

Your login screen should have a place where you can choose the desktop. I went with the choice “Plasma Full Wayland”.

When I previously tried (maybe a week or two ago), selecting txt for copy/paste with Wayland did not align with the mouse pointer. But that now seems to be fixed.

There is no reference in my login screen to Wayland for any desktop.

Hi
You can check what is running via;


echo $XDG_SESSION_TYPE

What is the output from:

ls -l /etc/alternatives/default-displaymanager

What does the following return?

zypper se -s wayland

If necessary do

sudo zypper in plasma5-session-wayland

session type is x11

ls -l /etc/alternatives/default-displaymanager
lrwxrwxrwx 1 root root 32 Dec 30 2018 /etc/alternatives/default-displaymanager -> /usr/lib/X11/displaymanagers/tdm

plasma5-session-wayland is already installed.

Show

ls -l  /usr/share/xsessions/

and

ls -l /usr/share/wayland-sessions/

For reference I have


lrwxrwxrwx 1 root root   42 Apr 28  2019 default.desktop -> /etc/alternatives/default-xsession.desktop
-rw-r--r-- 1 root root 7670 Oct 13  2018 gnome-classic.desktop
-rw-r--r-- 1 root root 7451 Apr 28  2019 gnome-xorg.desktop
-rw-r--r-- 1 root root 6821 Apr 28  2019 gnome.desktop
lrwxrwxrwx 1 root root   13 Mar 17  2019 icewm-session.desktop -> icewm.desktop
-rw-r--r-- 1 root root 2498 Mar 17  2019 icewm.desktop
lrwxrwxrwx 1 root root   15 Mar 28  2019 kde-plasma.desktop -> plasma5.desktop
-rw-r--r-- 1 root root 2353 Mar 28  2019 plasma5.desktop
-rw-r--r-- 1 root root 7368 Oct 13  2018 sle-classic.desktop
-rw-r--r-- 1 root root 2145 Dec 18  2018 twm.desktop

and


lrwxrwxrwx 1 root root   48 Apr 28  2019 default.desktop -> /etc/alternatives/default-waylandsession.desktop
-rw-r--r-- 1 root root 7550 Apr 28  2019 gnome.desktop
-rw-r--r-- 1 root root 1582 Mar 28  2019 plasmawayland.desktop
-rw-r--r-- 1 root root 7368 Oct 13  2018 sle-classic.desktop

FWIW, when Plasma (Wayland) is selected /var/lib/sddm/state.conf contains

# Name of the session for the last logged-in user.
# This session will be preselected when the login screen appears.
Session=/usr/share/wayland-sessions/plasmawayland.desktop 

I would guess that “tdm” is not setup to handle Wayland sessions. If you want to try Wayland, you will probably need to switch to “sddm”.

As root:

update-alternatives --config default-displaymanager

I was hoping tdm wasn’t the problem. I’ll be back…

Logout options are there here bottom left (TW-20191104). In full Wayland, all windows are disappearing top right of the desktop and unusable. Wayland seems to work, but did not investigate very long and prefer x11 session. Maybe not compatible with Kernel 5.4?

ls -l  /usr/share/xsessions/
total 12
lrwxrwxrwx 1 root root   42 Oct 31 14:07 default.desktop -> /etc/alternatives/default-xsession.desktop
lrwxrwxrwx 1 root root   15 Oct 31 14:07 kde-plasma.desktop -> plasma5.desktop
-rw-r--r-- 1 root root 2360 Oct 31 14:01 plasma5.desktop

ls -l /usr/share/wayland-sessions/
total 8
-rw-r--r-- 1 root root 1595 Oct 31 14:07 plasmafullwayland.desktop
-rw-r--r-- 1 root root 1571 Oct 31 14:01 plasmawayland.desktop

Half way there with this morning new Kernel. In full Wayland, taskbar shortcuts open normally, but not our 2 browsers = no access to the Internet, not even from the Kmenu. All apps open via the konsole, but not the browsers.

Full Wayland

echo $XDG_SESSION_TYPE
wayland
vlc
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)
[000056120cee0750] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000056120cf6c4f0] main playlist: playlist is empty
QObject::~QObject: Timers cannot be stopped from another thread
kate
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()



google-chrome-unstable
(google-chrome-unstable:5979): Gtk-WARNING **: 08:45:09.452: cannot open display: :1

cnf google-chrome-unstable                        
Program 'google-chrome-unstable' is present in package 'google-chrome-unstable', which is installed on your system.
Absolute path to 'google-chrome-unstable' is '/usr/bin/google-chrome-unstable'. Please check your $PATH variable to see whether it contains the mentioned path.

/usr/bin/google-chrome-unstable
(google-chrome-unstable:5930): Gtk-WARNING **: 08:42:43.373: cannot open display: :1

Wayland works normally, shorcuts and terminal.

/usr/bin/torbrowser-launcher
Tor Browser Launcher
By Micah Lee, licensed under MIT
version 0.3.2
https://github.com/micahflee/torbrowser-launcher
Launching Tor Browser.
Running /home/user_name/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/start-tor-browser.desktop
Launching './Browser/start-tor-browser --detach'...

Both are opening normally:

google-chrome-unstable
[9000:9000:1107/090149.708142:ERROR:sandbox_linux.cc(372)] InitializeSandbox() called with multiple threads in process gpu-process.

/usr/bin/google-chrome-unstable
tracing_service_impl.cc: Configured tracing, #sources:3, duration:0 ms, #buffers:1, total buffer size:25600 KB, total sessions:1
[9202:1:1107/090340.242505:ERROR:consumer_host.cc(259)] Timed out waiting for processes to ack BeginTracing: 9167 9205 
[9205:9205:1107/090340.263984:ERROR:sandbox_linux.cc(372)] InitializeSandbox() called with multiple threads in process gpu-process.
tracing_service_impl.cc: Tracing session 1 ended, total sessions:0
uname -r
5.4.0-rc6-4.gbe38a7b-default
rpm -qa | grep -i grub
grub2-snapper-plugin-2.04-2.1.noarch
grub2-2.04-2.1.x86_64
grub2-x86_64-efi-2.04-2.1.noarch
grub2-i386-pc-2.04-2.1.noarch
grub2-systemd-sleep-plugin-2.04-2.1.noarch
ruby2.6-rubygem-cfa_grub2-2.0.0-1.1.x86_64
grub2-branding-openSUSE-84.87.20191004-3.2.noarch
mokutil  --sb-state
SecureBoot enabled

The good news is that our computer DID NOT boot in MoK Manager since the fourth release candidate. Even the last Grub update passes the Secure Boot test.

Thanks once again for improving Tumbleweed.

NB: NumLock Keyboard is activated, but not responding on logout-login.

What is the difference between Wayland and Full Wayland ?

Ta

M

I guess that it means GTK and Qt backends are set to using Wayland only (something which has taken a lot of development to do)…

+Wed Aug 28 13:23:28 UTC 2019 - Fabian Vogt <fabian@ritter-vogt.de>
31+
32± Change 0001-Set-GTK_BACKEND-x11-in-a-wayland-session.patch to not
33+ override GDK_BACKEND if already set
34± Add a new plasmafullwayland.desktop which overrides use of X11
35+ backends of GTK and Qt
36+
37±------------------------------------------------------------------

I’ve tried to get Firefox running in a full wayland session (KF5, Tumbleweed) but without success. Firefox opens but it hangs, by double clicking on the title bar it loads the start page and sometimes you can enter something into the address bar and it loads it by double clicking on the title bar. One time I was able to insert the address about:support to see whether wayland is used or not but it was since I’ve started firefox from the command prompt with this command: env GDK_BACKEND=wayland. Is there a way to get firefox running in wayland mode in KF5?

I just tried this in a virtual machine (running Tumbleweed). And firefox starts but seems to hang.

Yes, reads like work in progress…

Does the following work ok?

firefox -safe-mode

The same problem. It seems to hang.

I should mention that “firefox” is fine with Plasma Wayland. It is only with FullWayland that there is a problem.

Maybe Gnome isn’t really “Full Wayland”.

Possibly related – Plasma Full Wayland cannot be started from “lightdm” (bug 1156232).