X hanging at init 5

What was your answer to my question about /home?

Are you re-using an existing /home, and if so, did you have special desktop effects enabled on that /home prior to this install ?

All I can say to that is I have same graphic hardware, running on SuSE, and it works. I have questions (such as /home) but you are not answering them all. I am trying to help …

Sorry I missed this question.
No I always changed the name of the user so the home was always different, i was especially careful when switching from 32 to 64 bit and every distro has its own /home

My wife’s PC with the 9200 pro is a 32-bit, so that is different. Still, I would be surprised if this is a 32-bit vs 64 bit issue.

Another possibility is the CD/DVD reader on this pc with the problem is decalibrated wrt the other pc’s where the installation CD/DVD was burned, and where it worked before. And hence each install is corrupted. Did you burn to the slowest speed possible on a high quality +R or -R CD/DVD (and NOT to an RW). Did the mediacheck pass as run by this PC?

The cd was burnt on this pc and used for the other where all went fine. The Good installation was from a RW media, this one from a -R one. Both passed the check media.

Did you burn at the slowest speed your burner allowed?

No. I refuse tu use 1x. 8x out of 48x was a fair compromise in my opinion. Anyway I made two clean installs on other machines from that same dvd, three clean other distro installs from RW-dvds… how many probabilities it’s the install?? I still can’t get WHY it should be the install…since I used the same disk to install sucessfully on other machines,and i tried three different disks (3 32 bit and one 64 bit)on this one with the same result, I don’t think the problem sits there.

One thing I always forgot to mention is that on ALL (and only) suse disks being them install one or live cds (the live cds do work fine, both 32 and 64 bit) I have to turn down resolution to 1024x768 (instead of the default 1280x1024).
If I keep the highest one the monitor goes “no signal” and the system hangs.

I followed the conversation, did everything you suggested, still with the same problem.
I DID burned my DVD at lowest speed. And I used successfully the same disk on other machines too.

What I still do not understand is that when I created xorg.conf, everything worked perfectly after the first reboot. But from the second reboot on the problem was there again

I think your refusal to burn at the slowest speed possible is a mistake. CD/DVD readers/burners do NOT have identical calibrations, and I have seen MANY times the effect of a fast burn causing a CD/DVD to work on one PC and fail on another. The uncertainty that this could be an issue is clouding the entire progression of this thread and it could be other suggestions are a complete waste of time. The fact is, we just don’t know, as that uncertainty will always be hanging over our head.

What sax2 apps do you have installed? What is output of:

rpm -qa '*sax2*'

Also, since you say this works EVERYWHERE other than openSUSE, how about taking those /etc/X11/xorg.conf files and trying them on openSUSE?

Does openSUSE fail with ALL arguments? Did you try (to see if Sax2 crashes) in run level 3 (boot directly there, do NOT go there via a failed boot to run level 5):

sax2 -p

What do you get ?

Did you try (and if sax2 does not crash):

sax2 -r -m 0=fbdev

and reboot and test.

Did you try (and if sax2 does not crash):

sax2 -r -m 0=vesa

and reboot and test.

How many graphic devices do you have on your PC ? One or Two ? If two, then two of the above sax2 commands are wrong.

Frankly, having a DVD successfully work on other PCs has to be the most over rated critieria for a DVDs functionality.

You need to check to see what changed. Did you update your kernel ? Did you update an xorg app (such as xorg-x11-driver-video or xorg-x11-driver-video-radeonhd) ? Is the xorg.conf still there ? What driver is being loaded in the xorg.conf file. What is in the file /home/user/.xsession-errors ?? What is in the file (toward the end) /var/log/Xorg.0.log. Do NOT post such logs here on this thread. Do NOT!! Instead put them on a paste bin site and provide here the URL.

What have you tried to recover? For example, when booting direct to run level 3 (do NOT go there via a failed run level 5), have you tried to create a new xorg.conf file with root permissions:

sax2 -p

(to learn what graphic devices are seen) followed by:

sax2 -r -m 0=fbdev

followed by a reboot, … or

sax2 -r -m 0=vesa

followed by a reboot, … or

sax2 -r -m 0=radeon

and if sax2 fails, what is in the sax2 log for each failed attempt ?

I’ll check it from home

Idid it following a different thread. I did use the Xorg.conf from Mandriva 2010 but it gave some kind of error as the syntax is different, I also tried to mix the two using the info from Mandriva and putting them in the Suse Xorg.conf. It didn’t like it.

Ubuntu does not have a xorg.conf by default (just as Suse), i did not reboot into it to have one created but it’s something I could try even if I DO Know that every distro uses a different syntax.

The old one from Suse 10.3 i did not keep, I had never imagined the mess this upgrade would be

Sax2 always fails… it Just freezes (and I always launch it from a failsafe session init3 from boot)
the log (as I already reported) says it goes through keyboard and mouse detecting end server (there it recognises the Radeon) then…nothing more…

Only than graphic card, no more


Sax2 always fails… it Just freezes (and I always launch it from a failsafe session init3 from boot)[/QUOTE]
Did you actually try “sax2 -p” ?? or are you basing that statement on trying sax2 with different arguments?

This precise command I did not try yet but I’ll be able to check it only later.
I’ll keep you posted

Now after many trials from home some updates

This was easy


Chip: 0 is → ATI RV280 5964 01:00:0 0x1002 0x5964 AGP radeon

At last it didnot crash, resolution is horrible, my eyes are aching and it seems i forgot my corrective lenses but anyway the system’s and X are there. I could boot it but it’s not usable.
Here’s sax’s log
/************* SaX2 log : - Sax_fbdev.log - j6KPR1a7 - Pastebin.com](http://pastebin.com/j6KPR1a7)
And xorg.conf included in sax log

I tried also

Sax did not crash but the screen went black with the warning “out of size”, by pressing esc I could go back to the prompt
Obviously it did not save the xorg.conf but the temp one it used is included in the SaX.log

/************* SaX2 log : - SaX_Vesa_Log - eXtzDiqR - Pastebin.com](http://pastebin.com/eXtzDiqR)

I tried again
sax2 -r -m 0=vesa
And all went as usual, blank screen, monitor in stand by, system hang

Did you try copy and pasting that into an xorg.conf file and then booting with that? Just a wild shot (and unlikely to work).

If I had access to my wife’s PC I would post her xorg.conf (from same graphic hardware) but she is using it heavily tonight (in MS-Windows) and won’t let me close to it :slight_smile:

What happens with:

sax2 -r -l -m 0=vesa

(thats a -L (lowercase))

Another possibilty is:

sax2 -r -u -m 0=vesa

if you type:

man sax2

you will get an idea as to the possibilities

I’m thinking one of these three files may be corrupted on your PC:

  • xorg-x11-driver-video
  • xorg-x11-driver-input
  • Mesa

You could try force a re-install of each of those 3 files.

I’ll try, read and see…
I think it should not be difficult to uninstall and reinstall those three packages

I looked for the xorg conf on my other machine which needed it not. I could have made it made but as it’s a quite different hardware (processor, screen, it also has an acquisition video card etc etc) i preferred not. Anyway even on that machine the driver with KDE is not working fine (bad image refreshment) Luckily it’s working fine with both Gnome and my favourite of the moment LXDE.

Suppose I have quite a long night of trials ahead… thanks

I checked my wife’s PC … turns out I was wrong, … her openSUSE-11.2 (running KDE4) has no xorg.conf file.

Here is the xorg.conf.install file from her PC which you could try to rename to xorg.conf: Section “Device” Identifier - Mrscpu xorg.conf.install - sc54ziwb - Pastebin.com

… of course, you could rename your pc’s xorg.conf.install to xorg.conf and see if that works instead - and that makes more sense.

The rpms she has installed:

oldcpu@mrscpu:~> rpm -qa '*driver*'
oldcpu@mrscpu:~> rpm -q Mesa

That made the trick!!
I uninstalled the three files with zypper and put them in again ran sax2 and it did not crash… it created an xorg.conf and at reeboot all was fine at last…
Thanks a lot for you never ending patience and help!

I put [solved] in topic… is that right?? Is that the way to do it??

Hope it’ll help also why137