X forwarding not working.

I’ve just done a fresh install of OpenSUSE 11.2. I am having trouble getting X forwarding over SSH to work. I edited the sshd_config to allow X forwarding and I restarted sshd. On my client machine I run windows, but have an X client which is known to be working(I can do X forwarding with an OpenBSD box just fine) is there some other additional configuration that I must do?

The error I am getting is


earlz@linux-s31z:/home/earlz> xterm &
[1]     7070
earlz@linux-s31z:/home/earlz> xterm Xt error: Can't open display: localhost:10.0

[1] +  Done(1)                 xterm &

also, display is set as so:


earlz@linux-s31z:/home/earlz> echo $DISPLAY
localhost:10.0

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Which SSH client are you using? Are you telling the client to forward X?
For the ‘ssh’ command this would simply be a ‘-X’ on the command line
typically. For putty there is an option in its session configuration to
tell it to forward X stuff.

Good luck.

earlz wrote:
> I’ve just done a fresh install of OpenSUSE 11.2. I am having trouble
> getting X forwarding over SSH to work. I edited the sshd_config to allow
> X forwarding and I restarted sshd. On my client machine I run windows,
> but have an X client which is known to be working(I can do X forwarding
> with an OpenBSD box just fine) is there some other additional
> configuration that I must do?
>
> The error I am getting is
>
> Code:
> --------------------
>
> earlz@linux-s31z:/home/earlz> xterm &
> [1] 7070
> earlz@linux-s31z:/home/earlz> xterm Xt error: Can’t open display: localhost:10.0
>
> [1] + Done(1) xterm &
>
> --------------------
>
>
> also, display is set as so:
>
> Code:
> --------------------
>
> earlz@linux-s31z:/home/earlz> echo $DISPLAY
> localhost:10.0
>
> --------------------
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJLOR9yAAoJEF+XTK08PnB5XywQAL+TLJAjeRbjli+wP4DZqAUv
Nmeknsivzd5Gt63hDQc6Onyco1jhJDvuNGDubWp2KrGU90FVswIX62lWAbcH/+ow
/xMk2qfBumy0Z+TSDDOfQMKTHu9X8SrNSmsriSTEB9Jp6fvlPBZw5vXEtfZcEefp
taCnB7oMMdDNYJP2cuwhjAMZ/oqvWOaupTddtPST21F0PgE4jpux/tCsGEozzIqB
yfsRg6nuFnAZP3y+bOvcaEGuMxd/LNGqPacJLtkIJlVSIiNPzyl6lhvatPH+bPSz
IEOuQml4NMziwGReExarbIploW67oSywFpOxmV77rFC/J0tUgbrajxZVaLXNWpj5
rTyz/9X6k10m1ES7Vevkrlckam+oe1ThxAP/6kUzm9YLUZOqFNckiYDt8oMP/xQI
ii0cgqRwMOrxoTgFq494KRHCLBqw+KfEoCn0K+JgtE/civh06Y28vo4PfoVofJ9Y
0fC5PL7Ctl7riUaZ+hSl2A23tnqAUusjGkh5ZMtPC1/KWpk2Bku8TM3MXHz8R3nj
HGAjz0WuATyvggpzIkZYq8SNy3bgThzdvwk2073MzHc+W3V5YFQ9z8XALidiGesg
/NmJy9+VVBeZehnxsKCuKGmthI75yGP5J0HrgJbwsFjcUHP7A+MTiP3/y+3GxMgb
v0NfkpGT2YjRvgerRknj
=9WTo
-----END PGP SIGNATURE-----

Yes, I’m using putty with X forwarding enabled(equivalent of ssh -X). And my X server and everything is installed and working client side. Like I said, I can do X forwarding to another machine, I’m just having trouble getting it to work with OpenSuse(SSH server side).

EDIT:

DOH! I forgot to start the X server on my client side… yea never mind. I’m an idiot. it works now

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

:slight_smile: No, we all do that once in a while.

Thanks for posting back.

Good luck.

earlz wrote:
> ab@novell.com;2094786 Wrote:
> Which SSH client are you using? Are you telling the client to forward
> X?
> For the ‘ssh’ command this would simply be a ‘-X’ on the command line
> typically. For putty there is an option in its session configuration
> to
> tell it to forward X stuff.
>
> Good luck.
>
>
>
>
>
> earlz wrote:
>>>> I’ve just done a fresh install of OpenSUSE 11.2. I am having trouble
>>>> getting X forwarding over SSH to work. I edited the sshd_config to
> allow
>>>> X forwarding and I restarted sshd. On my client machine I run
> windows,
>>>> but have an X client which is known to be working(I can do X
> forwarding
>>>> with an OpenBSD box just fine) is there some other additional
>>>> configuration that I must do?
>>>>
>>>> The error I am getting is
>>>>
>>>> Code:
>>>> --------------------
>>>>
>>>> earlz@linux-s31z:/home/earlz> xterm &
>>>> [1] 7070
>>>> earlz@linux-s31z:/home/earlz> xterm Xt error: Can’t open display:
> localhost:10.0
>>>> [1] + Done(1) xterm &
>>>>
>>>> --------------------
>>>>
>>>>
>>>> also, display is set as so:
>>>>
>>>> Code:
>>>> --------------------
>>>>
>>>> earlz@linux-s31z:/home/earlz> echo $DISPLAY
>>>> localhost:10.0
>>>>
>>>> --------------------
>>>>
>>>>

> Yes, I’m using putty with X forwarding enabled(equivalent of ssh -X).
> And my X server and everything is installed and working client side.
> Like I said, I can do X forwarding to another machine, I’m just having
> trouble getting it to work with OpenSuse(SSH server side).

> EDIT:

> DOH! I forgot to start the X server on my client side… yea never
> mind. I’m an idiot. it works now

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJLOTupAAoJEF+XTK08PnB5RHMP/jCS3pUqNX6zYqRjuA9mNBSv
JlPm7sjddPcZdxsJEWqPAuAxt1ENQ/D5gBc218lZTYDPjStVKdo2oigvfxAEQztx
JXEl5GTwjVUBJXDdIlxw240xx0853fLi0W9fdYKNP0z9kg/WjxmuFewJHOlwi4k8
VJLADm4UoXgFcq67rzfu7ksNgnGUSbFLW2IlNtvrYTcsiFEuVBUl6tSQNFNFsSiD
WXY97QS8y8/IFQy2x04WNM4DpeCj0Koj7NJDk16LDgUAevcSDTsTirHqCKCrWpbK
pDJNmQbNL4b/En0VMMsWyxMCJIa3g05OkuVHVdGdTLOYVg/seQT+xHfuSzzMRPSs
nWzyki4QWFO1IGNXNIx5p4l6a9JzQytFxlsIvf0w6speXYHXFl2hHWQSqDKpgbeQ
sOzkS70qXe8sgJ/zqd/3KEdZsDaaiwUScRHTwhuIha2/cuDjjVuRqCddYhEIn2j/
Ba1k5k7VU8AuhLT0aoijNjHN09rudU4Zw5Cm2/i4p2+G0xkc5ERTd3xbaT/ZndzK
55eR2aeLWXuJwpgE49h0W7rVdDgQut823f5h3eIIOvlZEgOuWxuSzjFaNzRm/Gc0
Hto3UA4GzYIQ3Nos7pxHDqnt3ZcOzTFQi1bYu4BVKai+XUJUWouEpSt8ZuHk6JOl
NEYy3UaNzSW5Nz11aiGZ
=gvj+
-----END PGP SIGNATURE-----

Which X server are you using? Xming comes with Xlaunch which will start up both the X server and a remote client via plink (from the putty project) with one click. Xming is free software, search for it.