X-Fi Xtreme Audio (PCI-E) NO MIC

Hello.

Device seems to be configured ok. Sound is playing but i can’t setup it to capture mic.

Some info.

Command: cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.22.1.

Command: cat /proc/asound/modules

0 snd_hda_intel

Command: cat /proc/asound/cards

0 [Creative ]: HDA-Intel - HDA Creative
HDA Creative at 0xfdbfc000 irq 17

**Command: cat /etc/modprobe.d/50-sound.conf **

options snd slots=snd-hda-intel

Ddhb.YhraNp3EzIA:SB1040

alias snd-card-0 snd-hda-intel

I’ve been browsing lots of article and didn’t fine the answer. Maybe sombody face the same problem.

I think the problem is with input configuration (port for mic is flexijack).

Maybe u need to find magic options here (I didn’t)?

/usr/src/KERNEL_VARSION/Documentation/sound/alsa/ALSA-Configuration.txt

In the mixer is the Mic ON?

All opitions visible and it looks like this.

http://bombaharris.nazwa.pl/kmix.png

I re-read your post a few times, and I can not tell if you are trying to capture sound to an internal mic, or an external mic via a jack in the PC, or via a USB mic. It makes a difference in the support information suggested !

Also, thankyou for the information you provided, but most of it is not so helpful, at least not for me when I am trying to figure out what is wrong. Does it mean something to you ? If so, perhaps you could teach me ? …

Anyway, I typically recommend the information suggested in our stickie be provided: Welcome to multimedia sub-area

… and I will quote for you :

Please post … providing in your post the following information:

/usr/sbin/alsa-info.sh 

and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
.
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

.
… some clarification on running the script “alsa-info.sh” … when you run:

/usr/sbin/alsa-info.sh 

you should get something like this (if it asks for an update, select NO):
http://thumbnails33.imagebam.com/9280/a5973e92794041.jpg](http://www.imagebam.com/image/a5973e92794041)

followed by this (select the SHARE/UPLOAD option):
http://thumbnails30.imagebam.com/9280/5e84f992794044.jpg](http://www.imagebam.com/image/5e84f992794044)

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :
http://thumbnails32.imagebam.com/9280/214da092794048.jpg](http://www.imagebam.com/image/214da092794048)

followed by this (where in RED is the URL).
http://thumbnails23.imagebam.com/9280/d9858092794051.jpg](http://www.imagebam.com/image/d9858092794051)

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on [Pastebin.com](http://pastebin.com) and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here ****

For your testing, whether it be for an internal integrated mic, or an external mic via a jack, or a USB mic, I recommend you use the program ‘arecord’ from a terminal, for example with this command:

  arecord -vv -fdat foo.wav

“foo.wav” is an arbitrary name I made up. Instead you could call it whatapain.wav or whichwaythewindblows.wav or anything … Then replay the recorded ‘foo.wav’.

My apologies for the long post. It takes time for me to put this together, and I would not have made the above requests/suggestions if I did not think providing the answers and doing the ‘right’ test were helpful.

I’ve got a X-Fi Xtreme Gamer and what I need to do to get my front input mic working is put the left bar of the Kmix input all the way down and one on right all the way up…

[LEFT]Like so ->
http://janbartspang.net/wp-content/uploads/2010/07/kmix2.jpg

[LEFT]I have no idea why but this seemed to be the only way I can get mine working…

This is what my kmix looks like. I only have Stereo speakers…

http://janbartspang.net/wp-content/uploads/2010/07/kmix.jpg
[/LEFT]

[/LEFT]

Test it in Krecord as OldCPU suggested… Also make sure the correct sound card is set in the KDE multimedia settings for communication… I have a USB webcam with a mic and this took priority, according to KDE at least, over my internal sound card…

OK sorry.

Im conecting a normal jack from headset directly to correct input on my card. Im not using FRONT_PANEL.

This is output of alsa-info.sh.

http://www.alsa-project.org/db/?f=a4367eef38f25273a5b6ec1f68c1936475cfddb9

PS. arecord didn’t capture anything.

Dexter of course i have been trynig your solution from this post
Even vist your blog :). It’s not working with. Btw other module is required for X-fi Xtreme Gamer.

Ok that is i think all u need.

Command :rpm -qa 'alsa

alsa-utils-1.0.23-1.8.i586
alsa-plugins-jack-1.0.23-1.9.i586
alsa-tools-gui-1.0.23-1.8.i586
alsa-oss-1.0.17-29.2.i586
pyalsa-1.0.22-1.8.i586
alsa-devel-1.0.23-2.12.i586
alsa-firmware-1.0.23-1.2.noarch
alsa-plugins-1.0.23-1.9.i586
alsa-1.0.23-2.12.i586

Command: rpm -qa 'pulse

libpulse-mainloop-glib0-0.9.21-10.1.1.i586
libxine1-pulse-1.1.19-1.pm.44.3.i586
libpulse0-0.9.21-10.1.1.i586

Command:rpm -q libasound2

libasound2-1.0.23-2.12.i586

Command :uname -a

Linux linux-mnro 2.6.34.7-0.5-desktop #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 i686 athlon i386 GNU/Linux

Output of alsa-info.sh

http://www.alsa-project.org/db/?f=a4367eef38f25273a5b6ec1f68c1936475cfddb9

Thanks. The installed rpms look ok, and based on your using kmix (I think) and also your PC having limited pulse audio rpms, it suggests to me you are using KDE. I assume KDE-4.4.4 and not a newer version? If a newer KDE version, forget my advice, as KDE is changing wrt sound in Linux in newer versions, and I am NOT on top of what is being done.

I looked at the diagnostic script output:

And I note this:

!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Creative]
Card hw:0 ‘Creative’/‘HDA Creative at 0xfdbfc000 irq 17’
Mixer name : ‘Creative CA0110-IBG
Simple mixer control ‘Line’,0
Front Left: Capture 115 100%] [6.00dB] off]
Front Right: Capture 115 100%] [6.00dB] off]
Simple mixer control ‘Mic’,0
Capture channels: Front Left - Front Right
Limits: Capture 0 - 127
Front Left: Capture 102 [80%] [0.50dB] [on]
Front Right: Capture 102 [80%] [0.50dB] [on]
Simple mixer control ‘IEC958’,0
Capture channels: Front Left - Front Right
Mono: Playback [on]
Front Left: Capture 115 100%] [6.00dB] off]
Front Right: Capture 115 100%] [6.00dB] off]
Simple mixer control ‘Digital’,0
Capture channels: Front Left - Front Right
Front Left: Capture 120 [100%] [30.00dB]
Front Right: Capture 120 [100%] [30.00dB]

On the surface, that looks ok.

There are a few settings that puzzle me, … I don’t think they should matter, but I do not know, maybe they do matter.

  • Your PC has simple mixer control ‘line’ muted, yet its capture is at 100%! Why put capture at 100% if you are going to mute it ?
  • Your PC has Mixer control IEC958 (I think thats an optical control) capture muted, yet its capture is at 100%! Why put capture at 100% if you are going to mute it ?

I suppose also there is the possibility that the driver configuration in alsa is mismatched, and you could try different mixer settings (recording carefully what you do) so as to ensure you do not repeat yourself, and you try all possibilities.

Note also, arecord has your PC as having 2 (not 1) record devices, for a total of 3 sub-record devices:
ARECORD

****** List of CAPTURE Hardware Devices ******
card 0: Creative [HDA Creative], device 0: CA0110 Analog [CA0110 Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
card 0: Creative [HDA Creative], device 1: CA0110 Digital [CA0110 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

I can’t see your hardware, so I can’t easily interpret that, but it makes me think you have a front jack, and a rear jack for your mic ? Did you try testing with both jacks at different times ?

Please also use the ‘arecord’ test I recommended.

I also note this from your dmesg as reported by the alsa diagnostic script:

   55.944061] hda-intel: Invalid position buffer, using LPIB read method instead.

 6240.194276] hda-intel: Invalid position buffer, using LPIB read method instead.

 6308.561207] hda-intel: Invalid position buffer, using LPIB read method instead.

 6512.979278] hda-intel: Invalid position buffer, using LPIB read method instead.

 6739.443563] hda-intel: Invalid position buffer, using LPIB read method instead.

 9034.285935] hda-intel: Invalid position buffer, using LPIB read method instead.

[62424.581178] hda-intel: Invalid position buffer, using LPIB read method instead.

[62861.779946] hda-intel: Invalid position buffer, using LPIB read method instead.

[64348.157948] hda-intel: Invalid position buffer, using LPIB read method instead.

[65155.785901] hda-intel: Invalid position buffer, using LPIB read method instead.
[65278.188057] ALSA pcm_lib.c:1752: capture write error (DMA or IRQ trouble?)
[65288.188380] ALSA pcm_lib.c:1752: capture write error (DMA or IRQ trouble?)
[67141.043287] ALSA pcm_lib.c:1752: capture write error (DMA or IRQ trouble?)
[67151.042055] ALSA pcm_lib.c:1752: capture write error (DMA or IRQ trouble?)
[67161.042268] ALSA pcm_lib.c:1752: capture write error (DMA or IRQ trouble?)

If you can not sort this, you may wish to consider writing a bug report, noting those errors in your dmesg.

http://bombaharris.nazwa.pl/device.png

As Dexter1979 wrote in his post . Maybe there is a problem.

The problem is that by default (X-fi extreme gamer not a X-fi xtreme audio but …) the recording device is set wrong and the microphone is used for a OUTPUT and not a INPUT

And i got one question.

/usr/src/KERNEL_VARSION/Documentation/sound/alsa/ALSA-Configuration.txt

Here i found options for my module snd-hda-intel. Is playing with it safe?

I suspect it should be safe. Keep a record of your original configuration before you change anything so you can roll back.

It may be easier to just write a bug report and get the openSUSE sound packager (who is also an alsa sound driver developer) to help you. There is guidance here on how to raise a bug report: openSUSE:Submitting bug reports - openSUSE on openSUSE-11.3 component “sound”. Use your openSUSE forum username and password when logging on to Novell’s bugzilla. Attach to your bug report the alsa-info.txt file you get from running:

/usr/sbin/alsa-info.sh --no-upload

noting that the attachment control is a bit obscure to find on the bugzilla (but it is there).

Also, the SuSE-GmbH packager will NOT read a forum thread, so ensure that your bug report has all the salient information.

Good Luck.

One of the biggest problems in my response is that I am comparing 2 different cards with 2 different chipsets and 2 different drivers… Looking around Google and the forums it looks like you shouldn’t have the module snd-hda-intel as your driver but it should be using and OldCPU was involved in solving someone elses problems with this card → Driver for Creative Labs Sound Blaster X-Fi Xtreme Audio (PCIE)

I am not entirely sure what the fix was but I think you need to update something and it’ll use a different module as it’s driver. This may solve your issues…

P.S. The X-Fi Xtreme Audio is actually not a X-Fi chip… It’s a fake! Bad sound card even under Windows compared to a real X-Fi…

Hey.

This card X-Fi Xtreme Audio is realy low profile card. Audigy 2 with crystalizer and thats it.

Thanks man i have been trying solution with updating alsa-kmp-desktop. No help.

Maybe somene will have the same problem so i left also this list.

Device support in ALSA is specific to the chipset within the device:

**snd-ctxfi **(EMU20K1, EMU20K2 chipsets)

  • X-Fi Elite Pro
  • X-Fi Fatal1ty
  • X-Fi Platinum
  • X-Fi Titanium
  • X-Fi Titanium Fatal1ty Champion
  • X-Fi Titanium Fatal1ty Professional
  • X-Fi Titanium Professional Audio
  • X-Fi XtremeGamer
  • X-Fi XtremeMusic

snd-ca0106 (CA0106 chipset)

  • X-Fi Xtreme Audio (PCI)

**snd-hda-intel **(CA0110 chipset)

  • X-Fi Xtreme Audio (PCI-E)

PS. Ok Device went back to China :). Im going to exchange it. Thanks ALL U GUYS for your time and HELP!

If you post the output of:

rpm -qa '*alsa*'
uname -a 

we can do a quality check on your alsa-kmp-desktop install, although that may simply indicate your install was successful and there are other X-Fi compatibility problems.

Cool, get a real XFi maybe? :wink: This should have little problems under Linux. My Xtreme Gamer (PCI) works like a treat…