X-Fi Titanium Fatal1ty Pro drivers install problem

Hello guys,

I just finished installing opensuse 11.4 on my desktop machine and unfortunately I have a problem with my sound card. I have downloaded the drivers from creative and I’m trying to compile and install them when I receive and [Error 2].

make -C /lib/modules/2.6.37.6-0.7-desktop/build M=/home/sepo/Downloads/X-FI_Titanium_Fatal1ty_Driver/XFiDrv_Linux_Public_US_1.00
make: *** /lib/modules/2.6.37.6-0.7-desktop/build: No such file or directory.  Stop.
make: *** [all] Error 2

Part of the file that generates the error looks like this:

ctxfi-objs := xfi.o ctatc.o ctvmem.o ctpcm.o ctmixer.o ctresource.o ctsrc.o ctamixer.o ctdaio.o ctimap.o cthardware.o cthw20k2.o cthw20k1.o
        
obj-m += ctxfi.o

ifeq ($(DEBUG), y)
CFLAGS += -g -DDEBUG
endif

KERNELDIR 	?= /lib/modules/$(shell uname -r)/build
PWD		:= $(shell pwd)

all:
	$(MAKE) -C $(KERNELDIR) M=$(PWD)

I think it has something to do with the kernel directory but I’m kind of new to linux and I don’t really know how to fix this.

Does anyone have any idea what might be wrong and how can I fix it?

Best regards,
Sergiu

So I have the X-Fi Titanium Fatal1ty installed and I did not need to compile any drivers. My only issue is that my nVIDIA video card also has a sound output. So, I must go to YaST / Hardware / Sound, make sure all sound devices are edited and installed and then using the Other button on the bottom right, set the Creative sound card as card zero, first and default. openSUSE 11.4 uses PulseAudio by default. The utilty called the Pulseaudio Volume Control (pavucontrol) can help select the proper output device on this card. pavucontrol is installed by default with GNOME, but not for KDE even thought it works fine with KDE, If you use KDE, go into YaST / Software / Software Management, search on pavucontrol and install the file if not already installed. Come back with any questions on this application if you have them.

Thank You,

Thanks a bunch jdmcdaniel3! It worked. I saw the drivers on the manufacturer’s site and I just jumped on compiling and installing stuff.

Best regards,
Sergiu

Thanks a bunch jdmcdaniel3! It worked. I saw the drivers on the manufacturer’s site and I just jumped on compiling and installing stuff.

Best regards,
Sergiu

Happy to be of help ssergiu. I actually did use their open source driver when it first came out, before it went into the kernel, but it was kind of fluky in operation. We are much better now with the built in support.

Thank You,

Hello again guys,

I haven’t created a new post because it’s mainly related to the same issue(the sound card).

I’m trying to make the microphone of the sound card mentioned above, work, but for some reason it’s not working. I tried with skype and audacity and nothing.

I am using alsa + pulseaudio. Below are some screenshots with pulseaudio config and alsa mixer display.

http://img580.imageshack.us/img580/2406/alsamixer1.png

http://img9.imageshack.us/img9/214/alsamixerj.png

http://img822.imageshack.us/img822/1681/pulseaudio.png

http://img101.imageshack.us/img101/98/pulseaudio1.png

Any input is appreciated.

Thanks,
Sergiu

Hi,

I can’t edit my previous post so I’m writing a new one. I noticed that my mixer is looking kind of incomplete. I was trying to follow this Getting Skype to work with a Creative X-Fi on OpenSUSE 11.3, KDE 4.4.4 blog post but I don’t have the mentioned options in the mixer.

http://img43.imageshack.us/img43/1813/mixero.png

Thanks,
Sergiu

Can you run a diagnostic script and post here the website/URL that is provided by the script with your PC’s sound configuration ?

With your PC connected to the internet, run the script as a regular user with the command:


/usr/sbin/alsa-info.sh

and select the share/upload option. Then once the script is complete, note the website/url address it provides and post that address here. DO NOT post the output of the script here as it will flood the thread and make the thread totally unreadable. JUST post the URL.

wrt puavucontrol screen prints, when doing a screen print of ‘input-devices’ ensure you have SHOW set to ‘all input devices’ and NOT to ‘all except monitors’.

Also, when doing a screen print of the ‘recording tab’ (which you did not provide) please ensure you have SHOW set to ‘all streams’ and also you run pavucontrol when trying to record.

Also, in pavucontrol, under the ‘configuration’ tab, what other options do you have besides ‘analog stereo duplex’ ?

For testing, I recommend one use the simple arecord command. For example, when trying to record with my webcam’s mic (which is hw:1,0), I use the command:


arecord -f S16_LE -c 2 -D hw:1 -vv new.wav

but there are many other permutations of ‘arecord’.

Hi oldcpu,

Thanks for your fast reply. I managed to make it work by uninstalling pulseaudio and following the instructions from the above blog. I’m not sure why it didn’t work with pulseaudio but at the end of the day I’m kind of a new guy in Linux world :).

Regards,
Sergiu