x-fi driver OpenSUSE 11 rc1


I tried to get my creative x-fi music to work, but I couldn’t compile the drivers.

checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes             
checking whether we are cross compiling... no            
checking for suffix of executables...                    
checking for suffix of object files... o                 
checking whether we are using the GNU C compiler... yes  
checking whether gcc accepts -g... yes                   
checking for gcc option to accept ANSI C... none needed  
checking for ranlib... ranlib                            
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E            
checking for egrep... grep -E                               
checking for ANSI C header files... yes                     
checking for an ANSI C-conforming const... yes              
checking for inline... inline                               
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no                     
checking for current directory... /opt/Creative/XFiDrv_Linux_US-1.18/drivers
checking cross compile...                                                   
checking for directory with kernel source... /lib/modules/
checking for directory with kernel build... /lib/modules/  
checking for directory with ALSA include files... /lib/modules/
checking for kernel linux/version.h... yes                                                        
checking for kernel linux/autoconf.h... yes                                                       
checking for kernel version...                                               
checking for GCC version... Kernel compiler:  Used compiler: gcc (SUSE Linux) 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]

*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.

checking for built-in ALSA... no
checking for existing ALSA module... yes
checking to modify of kernel linux/kmod.h... no
checking for kernel linux/compiler.h... yes    
checking for kernel linux/pm.h... yes          
checking for kernel linux/spinlock.h... yes    
checking for kernel linux/irq.h... yes         
checking for kernel linux/threads.h... yes     
checking for kernel linux/rwsem.h... yes       
checking for kernel linux/gameport.h... yes    
checking for kernel linux/devfs_fs_kernel.h... no
Creating a dummy <linux/devfs_fs_kernel.h>...    
checking for kernel linux/highmem.h... yes       
checking for kernel linux/workqueue.h... yes     
checking for kernel linux/dma-mapping.h... yes   
checking for kernel asm/hw_irq.h... no           
Creating a dummy <asm/hw_irq.h>...               
checking for kernel linux/device.h... yes        
checking for kernel linux/platform_device.h... yes
checking for kernel linux/jiffies.h... yes        
checking for kernel linux/compat.h... yes         
checking for kernel linux/adb.h... yes            
checking for kernel linux/cuda.h... yes           
checking for kernel linux/pmu.h... yes            
checking for kernel linux/moduleparam.h... yes    
checking for kernel linux/syscalls.h... yes       
checking for kernel linux/firmware.h... yes       
checking for kernel linux/err.h... yes            
checking for kernel linux/bitmap.h... yes         
checking for kernel linux/mutex.h... yes          
checking for kernel module symbol versions... yes 
checking for PCI support in kernel... yes         
checking for I2C driver in kernel... module       
checking for firmware loader... module            
checking for input subsystem in kernel... yes     
checking for directory to store kernel modules... /lib/modules/
checking for ISA support in kernel... no                                                        
checking for processor type... x86_64                                                           
checking for ISA DMA API... yes                                                                 
checking for 32bit compat support... yes                                                        
checking for SMP... yes                                                                         
checking for Video device support in kernel... yes                                              
checking for strlcpy... no                                                                      
checking for snprintf... no                                                                     
checking for vsnprintf... no                                                                    
checking for scnprintf... no                                                                    
checking for sscanf... no                                                                       
checking for vmalloc_to_page... no                                                              
checking for old kmod... yes                                                                    
checking for PDE... no                                                                          
checking for pci_set_consistent_dma_mask... no                                                  
checking for pci_dev_present... no                                                              
checking for msleep... no                                                                       
checking for msecs_to_jiffies... no                                                             
checking for tty->count is the atomic type... no                                                
checking for video_get_drvdata... no                                                            
checking for io_remap_pfn_range... no                                                           
checking for new io_remap_page_range... no                                                      
checking for kcalloc... no                                                                      
checking for kstrdup... no                                                                      
checking for kzalloc... no                                                                      
checking for create_workqueue with flags... no                                                  
checking for saved_config_space in pci_dev... no                                                
checking for register_sound_special_device... no                                                
checking for RTC callback support in kernel... no                                               
checking for HPET support... yes                                                                
checking for Procfs support... yes                                                              
checking for class_simple... no                                                                 
checking for old driver suspend/resume callbacks... no                                          
checking for removal of page-reservation for nopage/mmap... no                                  
checking for nested class_device... no                                                          
checking for new unlocked/compat_ioctl... no                                                    
configure: creating ./config.status                                                             
config.status: creating Makefile.conf                                                           
make: *** [all] Fehler 2                                                                        
make: *** [install] Fehler 2                                                                    
Installation Unsuccessful

kernel-source and the basic development system is installed…

Does anyone know what to do?

I have this same problem, except in english. I’m using opensuse 10.3 and uname -r says I have kernel
I don’t know if that is the kernel I’m using. I do know is the version of my kernel source.

My system:
intel 945gpm
intel D 830
X-fi platinum

This is a fresh install of opensuse 10.3. I just have the xwindow install with developmental package.

I would love to get this working. Thanks in advance.

Can nobody solve this problem? :confused:

In which directory are you trying to compile this? Do you have write permissions to this directory? IMHO you should be logged on as a regular user, and you should try to compile this in your home directory, in a directory such as /home/username/someapplication

Can you also confirm you have gcc43 and gcc43++ installed.

What drivers are you trying to install? alsa? oss?

If alsa, why are you compiling, instead of using a packaged rpm:
Alsa-update - openSUSE

And finally, the x-fi does not have good support in Linux, as noted here:
Creative X-FI - poor linux support
where it basically states no linux support. … however I have read there is a beta ( ? ) OSS driver that will work with this device.

Hey this is the EXACT same problem I’m having with the exact same device, in fact I started a thread earlier today with the same issue.

While I haven’t yet tried to newest ALSA configs, I can confirm that the OSS drivers do function, although without any option for mixer or 5.1 surround

Yes. The FIRST thing I’d do is get your distro upgraded!
[Hint: RC1 is ancient history…11.0 has been finalized.]

So, do:

zypper ref && zypper dup

and get upgraded and patched. THEN, try to solve your
app problems.

My 2-cents…

Yes, I know. The download is currently running, but both mirror servers in Austria are very slow today :rolleyes:,so it could take some time…

I’m now up-to-date and I tested it in my home/x-fi directory. The same errors appear. The gcc43 and gcc43++ are installed.
The output I posted is from the closed-source beta driver installation!
Where can I download the OSS driver?

Unfortunately the Creative X-Fi driver is BADLY broken.

I’ve been able to get it to compile vs 11.0 but unfortunately there are several issues - which ALL are due to the fact that the drivers are dismally coded. Getting them to compile on any newer distribution require changes in the C code itself, changing the module startup properties and some other fixes.

I’ll see if I can package them as an RPM (I’m pretty new at this RPM packaging thing so give me some time :stuck_out_tongue: ) and put them up somewhere. No promises however.

Ok, I have enough time to wait… :wink:

Well, I’m glad to announce that the Creative drivers are now officially the worst in history. I have never, in my entire time of using computer, seen drivers that crash my machine so hard as these. Congratulations Creative, you brainless monkeys.

Not only do they crash, they literally shut the whole system down. modprobe the drivers and the entire system goes black and power cuts.

Suggestion: let’s wait until ALSA guys get their driver out.

Well… I belive that Creative is heading downwards from here… They will go down, licking microsoft butt…:rolleyes:
I have a Creative X-fi pro, but i will base my choice of purchase by operatingsystem from now on… Check that it got support for linux… :stuck_out_tongue:

I think I should change this f**kin’ X-Fi into a M-Audio Revolution :mad:

Thanks god, OSS v4.0 build 1016 (4Front Technologies) works fine with opensuse 11.0, but there is no possibility to use microphone :frowning: Anyway waiting for first Alsa-project driver

I think I need no microphone and if I need one I can use the onboard-chip…

Congratulations Creative, you brainless monkeys.

That’s the reason my X-fi is unplugged. I removed Windows and had no choice but to remove my beloved X-fi as well. Could not get the drivers to work properly. Any audio that was produced was bad quality. Also, could not configure it with Alsa OR Yast2-Sound. My internal soundcard worked fine at first boot.

I might just sell the darn sound card. X-Fi anyone? :smiley:

A few google attempts reveal that the problem is caused by the **** drivers loading modules in the wrong order. I found a post on Gentoo’s wiki: HARDWARE Creative Labs X-Fi - Gentoo Linux Wiki

Someone I know had luck with that, I’m wondering if the instructions can be modified to work with SUSE. Waiting for ALSA to release their driver seems like the safest option.