X fails to start after updates today

I did an update today, i usually do them daily as the notifier pops up and now X won’t start. I get a lot of error messages in Xorg.0.log like

module ABI major version (8) doesn’t match server’s version (10)

Saw a similar post from today here

General discussion of the openSUSE project

but no solution. Can anyone suggest what packages i should downgrade to get up and running again?


I’ve just run that zypper dup update (large number of packages + includes kernels). I had no problem. What can it be? I have long ago uninstalled systemd and preload because one of them interferes with VirtulBox and the other generates endless minor error messages at boot time (can’t remember which is which). In any event, the error message you linked in is reminiscent of systemd’s bugginess, so you might try uninstalling that, and maybe preload too (neither are actually needed IIRC). OTOH they might be irrelevant, but shouldn’t hurt to try it.

i should probably pay more attention to which updates are coming in if i’m going to roll with tumbleweed. i normally glance over them and i’m pretty sure there weren’t any kernel updates in today’s batch. i didn’t have systemd installed, and removed preload with no luck. i did read about a way to get past the ABI warnings by running

startx – -ignoreABI

and now it appears to want to start but segfaults,

   212.263] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
   212.263] (WW) Falling back to old probe method for fbdev
   212.263] (II) Loading sub module "fbdevhw"
   212.263] (II) LoadModule: "fbdevhw"
   212.263] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
   212.270] (II) Module fbdevhw: vendor="X.Org Foundation"
   212.270] 	compiled for 1.10.4, module version = 0.0.2
   212.270] 	ABI class: X.Org Video Driver, version 10.0
   212.270] (WW) Falling back to old probe method for vesa
   212.271] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x46b1f8]
   212.271] 1: /usr/bin/Xorg (0x400000+0x5efb9) [0x45efb9]
   212.271] 2: /lib64/libpthread.so.0 (0x7f515d0dd000+0xf2d0) [0x7f515d0ec2d0]
   212.271] 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f515a692000+0xe039) [0x7f515a6a0039]
   212.271] 4: /usr/bin/Xorg (xf86DeleteScreen+0x7c) [0x5270fc]
   212.271] 5: /usr/bin/Xorg (InitOutput+0x872) [0x46e732]
   212.271] 6: /usr/bin/Xorg (0x400000+0x258fd) [0x4258fd]
   212.271] 7: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f515c06fbfd]
   212.271] 8: /usr/bin/Xorg (0x400000+0x25659) [0x425659]
   212.271] Segmentation fault at address 0xc358
Fatal server error:
   212.271] Caught signal 11 (Segmentation fault). Server aborting

maybe i’ll get lucky and some upates tomorrow will fix things up again.

I have the same problem.

ignoreABI don’t work.

I recompile the video drivers and work. (intel,vesa,fbdev).

I have the very same problem and I cannot solve it.
I’ve tried updating/downgrading xorg, radeon drivers, etc and nothing worked.

Any help will be much appreciated.


Ok, added Xorg/X11 repo. Did “zyper ref” and “zypper up” and reboot.
Everything is ok now. So maybe chronotherapy works after all.

yeah a zypper dup today fixed me too