X fails - Radeon 3870 X2


I tried to install from the Live CD. But what I got was an error from X. So I was stuck with a prompt.

I think it was this bug:
[radeonhd] [Bug 21686] New: Broken connector table](http://lists.opensuse.org/radeonhd/2009-05/msg00141.html)

Same error:
(EE) RADEONHD(0): Card information has invalid connector information

Anyone had any luck with that?
Would it be different if I used the DVD to install?

I’ve got a ATI Radeon 3870 X2 video card, by the way.

You can switch to vesa for now:

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA.
Remove all text and now type just the number:
and hit enter
at the login type your user name and then password
now type:
then the root password
now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)
now reboot
if you don’t get a gui login
login as user and try this at the cli

ATI - openSUSE

Downloaded the DVD installer. That one did work. Well, the video did. But installing GRUB didn’t work. I have a software RAID and a dual-boot with Windows.

Check this out it may help you.
Watch a SUSE 11.1 install Slideshow - openSUSE Forums

I’ve already seen the installation. :wink:

And it went perfect with the DVD installer (video OK now), except for installing GRUB. But that’s not my fault…

except for installing GRUB. But that’s not my fault…

I’m inclined to disagree. Grub only goes where you tell it. You almost certainly need it to the MBR, the slideshow shows that being set in the install too.

You could check this too
openSUSE 11.1 Install - Step by Step Photo Progression + Video - By carl4926

see: http://files.myopera.com/carl4926/albums/671478/19.png

I’m telling you: it wants to install to MBR. And I can’t choose where to install it in the OpenSUSE installation.

Thus it is not my fault!

If it wants to install to MBR then that is where it will go. If you think you need it somewhere else and it will not go - that’s because you have other settings (perhaps in the bios for disc order) incorrect.

Tell us what you want. What you have; disc’s partitions etc… and we might be able to help