X Error of failed request: BadAlloc (insufficient resources

I’ve Opensuse 11 and an Intel Graphic Card.

Everytime I try to play a video using VLC; or any other video application (mplayer, tomtem)… the system crahes.

I’ve got the following error:

X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 142 (XVideo)
Minor opcode of failed request: 19 ()
Serial number of failed request: 84
Current serial number in output stream: 85

After searching google I found that it is a bug related to the Xorg, and some sites are pointing to fix, but the site is unavailable: http://beta.suse.com/private/sndirsch/bug345131/

Can someone help me?


Hi. It is a bug in Xorg. Edit the file /etc/X11/Xorg.conf. Reach the section “device” and add those lines:
Option “Videoram” “65536”

Option “Cachelines” “1980” then halt and restart x server

Are you using visual effect (compiz)? If so, turn it off, and the problem should disapear. There are other posts on this topic on the forum if you do a search.

I ran into this problem myself


Thread moved to Applications

I’m running Compiz+emerald on an intel 945gm. I had the same problem even with 3d effects off. But now it works like usual. Just add those two lines to xorg.conf.It is a known bug in xorg about the intel video cards.

really? is your video working after your fix with compiz on?

Yes it is working perfectly after the changes i made to xorg.conf. I found it on a fedora forum and since it is not related to the distro but on x it works!

I am currious what the 65536 and 1980 refer to?

Just read “man intel”

Hello all. I have the same problem. Im running openSuse 11 on Fujitsu-Siemens amilo Si2636.

lspci -vvv shows:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Fujitsu Siemens Computers Device 111f
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at fc000000 (64-bit, non-prefetchable) [size=1]
        Region 2: Memory at d0000000 (64-bit, prefetchable) [size=256]
        Region 4: I/O ports at 1800 [size=8]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
                Address: 00000000  Data: 0000
        Capabilities: [d0] Power Management version 3
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
                Bridge: PM- B3+

i did what you recommended - i changed the Xorg.conf. Doesnt help. I also read the manpages for the Intel driver. There its written that:

The VideoRam option, which in the past had been necessary to allow more than some small amount of memory to be allocated, is now ignored.

So thats probably why it doesnt help.
VLC runs ok when i turn of the desktop effects.

BUT dont tell me that a power-ridden machine like this (Intel Core2Duo T8300 @ 2.4Ghz with integrated Intel Gl960 with 256MB RAM) CANT handle movie playback and a few shitty window effects AT ONCE.

Why isnt this submitted as a bug yet ??[/size][/size][/size]

Hi. I only can guess your chip i965 is not so well supported by the very poor intel driver. Actually my laptop is a fujitsu-siemens amilo si1520 but i have i945gm so the experience could be different. The only thing i can say is that yes specifying the amount of Videoram could be obsolete but it has been the only cure i did. So maybe that even man is buggy! Now vlc,mplayer and Xine work great with Compiz on. Anyway this driver is buggy. I still use as main system Opensuse10.3 and 11.0 as second choice. But even 6 months ago i had to fall back to the good old i810 driver. Could it be closer to the solution? Something is really going crazy whit the intel chipset drivers. Even the new iwi3945 is a ******* in the respect of the old driver. A lot to complain. Is this a way to make us switch to windoze? I’ll google if i can manage this problem

Hello all,

i’ve come upon a solution to fix this problem - works at least for me - (see my config up in the posts).
I’ve been checking the bug description of this problems here: https://bugs.launchpad.net/fedora/+bug/111257 - there sprang out the name Carl Worth who is working on a EXA acceleration method with the intel open source driver. So i just tried what does it do, and seems like i can watch movies without BadAlloc and also use the desktop effects, even though i feel they are slower then without this “fix”.

just delete the cachelines and videoram option from xorg.conf it it doesnt work for you, and add:

Option “AccelMethod” “exa”

into the device section.

maybe i found out something everybody allready knows, but i couldnt find this anywhere so maybe it can help to people who experience simillar problems with the intel driver.

I’ve filed a bug against openSUSE 11.0, in the “X” category: https://bugzilla.novell.com/show_bug.cgi?id=413505

Exactly 1 hour after I had filed a bug (see previous post) Stefan Dirsch from openSUSE support came up with this advice:

Please try in ‘Section “Device”’

Option "AccelMethod" "XAA"

Restart Xserver afterwards.

And that’s it. Everything works fine now. :slight_smile: