X doesn't start with nVidia Drivers with GT 550M (nVidia Optimus)

No, they do not always need xorg.conf …I have two openSUSE-12.1 installs on different hardware (FX5200 on one PC, and GTX260 on another PC) using different nvidia proprietary graphic drivers and NEITHER has an xorg.conf file.

It really all depends on the specific nvidia card and one’s monitor, how well they are supported (IMHO).

interesting. in my case having nvidia drivers generate (both from repo and .run) xorg.conf result in X doesn’t starting at all. deleteting that xorg.conf boots into something that looks like failsafe mode. and as i mentioned fefore - using xorg.conf from bumblebee outputs evedyting on external monitor , but nothing on laptop

Sounds like you are missing glx-extensions for the Intel chip, that chip is wired to the internal display, this happens if you install the Nvidia driver “the hard way” and possibly also with the one-click. Look here:

ls /usr/lib/xorg/modules/updates/extensions/
libglx.so libglx.so.285.05.09

and here:

ls /usr/lib/xorg/modules/extensions/
libdbe.so libdri.so libglx.so libvnc.so
libdri2.so libextmod.so librecord.so

This is the layout the repo installation uses, the “hard way” would overwrite the original xorg libglx.so in /usr/lib/xorg/modules/extensions and you won’t get it back by uninstalling the driver. The “hard way” will also overwrite the original /usr/lib/libGL.so, whereas the repo installer will put it’s version under /usr/X11R6/lib. The Intel driver will not work with anything but the original xorg libglx.so and libGL.so. To get them back you’ll have to reinstall the package xorg-x11-server, after switching to the repo nVidia installation.
I’m on 32-bit so change all “lib” in my paths to “lib64”.

ok ,just to make sure , 1click , repisitory , and the hard way are three distinkt methods of installing nvidia drivers. i thought that 1click and repository way are the same so i haven’t tried repo way.

I’ve given up on it… :frowning: Everything I’ve tried leads to a dead end… NVidia is not giving any input either. I suppose I’ll have have to wait and see if some bright spark figures it all out. Meanwile - looks like Windows 7 is the only options http://forums.opensuse.org/images/smiliesnew/crying.png

Just in case someone stumbles uppon this thread I’ll post my solution to this situation.

So I have Dell XPS17 (L702x) vin Nvidia Optimus and two main issues aound that:

  1. Need to be able to use Nvidia for better performance
  2. Need to use external monitor, but HDMI does not work

Solution to problem 1.

Since OpenSuse KDE interface performace is fine when running on integrated intel card, I left it be. I did install nvidia drivers from repository (repository way) and I did install Bumblebee from Unstable (didn’t have ay isues so far) OpenSuse 12.1 branch. Since I’m happy with my laptop’s performce for general tasks I didn’t try to rn KDE session with optirun and only start application I want to use NVidia with optirun so I get that extra performance.

Solution to problem 2.

Since HDMI doesn’t work, I’ve bought mini displayport to hdmi converter (only cost a few GBP) and connect my external monitor that way. This worked stright away and I could configure my dial monitor layout from System Settings (don’t have to use Nvidia Settings).

Note, I’ve only had a chance to play with Dell L702X. Same solution might not work on all Optimus laptops

I have this problem on my ASUS N53 too with this nvidia 550M.
Will OpenSuse fix this problem for 12.2 version?
or use another linux distro?

This is not an OpenSuse problem. The Optimus system is designed to only work with Windows 7 and latter. The last I heard, Nvidia was not going to support Linux or any other operating systems. So if you are not using Win 7 or 8 you will have to wait for someone to work it out.
I have found the intel chipset works fine for most things I do now. I would like my HDMI port working though.

Hi RaveNBlack,

I know that you given up on this quite a while.

Anyway, here’s my story, maybe it’ll help you or others :

  • I have an Acer Aspire i7 with the exact same graphic card as you : nvidia GeForce GT555M.

Guess what ? Optimus support through Bumblebee works for me.

Follow this thread to make it work and specifically read the post of futadict http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/469419-opensuse-12-1-optimus-laptop.html#post2434145 to make it all work.

This is really a great how-to (when it works :wink: ) : http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/469419-opensuse-12-1-optimus-laptop.html

Good luck to you all. :slight_smile:

Thanx DaaX, I’ll check tehm out as since updating nvidia drivers to 295 version from repo last night I’ve lost nvidia drivers completely. modprobe tells me that there is no such hardware and it cannot load nvidia.ko

This thread might be a bit old… but here is what I did for fedora and it does work for OpenSuse as welll… you have to append the acpi=noacpi option to the boot arguments… that will let you start X, then go and blacklist the noveau driver.
You’ll be running fine on the HD 3000 graphics… after that go ahead and install bumble bee to use it as needed.

I think you’ll find this kernel option has more to do with your particular hardware, than a general requirement for those with Optimus graphics. Thanks for your contribution all the same.

Here’s a guide for those who come searching: