X does not start after reboot from Xemacs hangup.

I was just programming as a normal user (not root) when Xemacs(ESS) hung up because of lots of output - Xemacs did not react to stop button or ESC-ESC and I could not activate any other window.
Waited a minute or two and tried an ordinary reboot from within X/KDE with the result that now X does not start. I get:

(II) Loading /usr/lib64/xorg/modules//extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.5.2, module version = 1.0.0
	ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI

0: X(xf86SigHandler+0x65) [0x489be5]
1: /lib64/libc.so.6 [0x7fb7dc7d46e0]
2: X(InitOutput+0x508) [0x467858]
3: X(main+0x286) [0x4324c6]
4: /lib64/libc.so.6(__libc_start_main+0xe6) [0x7fb7dc7c0586]
5: X [0x431a79]

Fatal server error:
Caught signal 11.  Server aborting

Should probably mention that sax2 -p gives:
Chip: 0 is -> NVIDIA GeForce 7025 / NVIDIA nForce 630a 00:18:0 0x10de 0x053e PCI nvidia

Solved: reconfigured dualhead/twinview with sax2 as root.