X crash when skype receives video with fglrx driver

Hi, I am writing here a problem that I have lately in case someone has managed to solve it.
I have openSuSE 13.1 installed on my laptop, which is a sony vaio EB1Z1E.
Till some time ago I had the radeon driver installed and spyke was working perfectly with no problems.

Lately, I installed the fglrx proprietary driver. Since then I can use skype for voice calls and I can also send video, but when the other end starts it’s camera then my desktop reboots and it takes me to the login screen.

I have searched on the internet, and though it seems that there are people facing this problem I haven’t managed to find a working solution. I also tried looking in the log files but I couldn’t find anything that looked helpful (to my understanding, though I am not an expert), apart maybe from the following part of Xorg.0.log

   365.961] (EE)
   365.961] (EE) Backtrace:
   365.961] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x49) [0x81df3e9]
   365.961] (EE) 1: /usr/bin/Xorg (0x8048000+0x19b174) [0x81e3174]
   365.961] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb770640c]
   365.961] (EE) 3: /lib/libc.so.6 (0xb71e7000+0x1368bf) [0xb731d8bf]
   365.961] (EE) 4: /usr/lib/xorg/modules/glesx.so (0xb3d98000+0xfedad) [0xb3e96dad]
   365.961] (EE) 5: /usr/lib/xorg/modules/glesx.so (0xb3d98000+0x108713) [0xb3ea0713]
   365.961] (EE) 6: /usr/lib/xorg/modules/glesx.so (0xb3d98000+0x1088fa) [0xb3ea08fa]
   365.961] (EE) 7: /usr/lib/xorg/modules/glesx.so (0xb3d98000+0x20d299) [0xb3fa5299]
   365.961] (EE) 8: /usr/lib/xorg/modules/glesx.so (0xb3d98000+0x7c2e5) [0xb3e142e5]
   365.961] (EE) 9: /usr/lib/xorg/modules/glesx.so (0xb3d98000+0x79914) [0xb3e11914]
   365.961] (EE) 10: /usr/lib/xorg/modules/glesx.so (esutUpdateSurfData+0x2e) [0xb3e1095e]
   365.961] (EE) 11: /usr/lib/xorg/modules/amdxmm.so (X740XvPutImage+0x650) [0xb3d63d40]
   365.961] (EE) 12: /usr/bin/Xorg (0x8048000+0x9253c) [0x80da53c]
   365.961] (EE)
   365.961] (EE) Segmentation fault at address 0xaffc3000
   365.961] (EE)
Fatal server error:
   365.962] (EE) Caught signal 11 (Segmentation fault). Server aborting
   365.962] (EE)
   365.962] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
 for help.
   365.962] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
   365.962] (EE)
   365.962] (II) AIGLX: Suspending AIGLX clients for VT switch
   365.963] (II) fglrx(0): Backup framebuffer data.
   365.967] (II) fglrx(0): Backup complete.
   367.175] (EE) Server terminated with error (1). Closing log file.

I would be grateful if someone has a solution, or can help me resolve the problem.
I know I can always revert to the radeon driver, but since I think that the proprietary driver has better power managment, I would prefer not to.

Thank you very much

PS: I have read some old posts about xv causing troubles and I have tried the solution here posted, but then the Xserver doesn’t even start.