Wyse 50 terminal emulator?

Hey y’all

I have an OpenBSD server and I access i’m trying to access it via serial port with a Opensuse computer. I have been using Minicom but its 2 emulation types (vt102 and ANSI) Dont seem to be working for me. Is there a terminal emulator for linux that supports wyse50? That would be best.


Why can’t you set your openbsd server to expect an ANSI, vt100 or similar terminal type on the serial port?

I tried to set it so vt100 and vt102 and for the most part that seems to work but i cannot backspace is vi editor i tried changing what the backspace button send with minicom but neither work for me.

Perhaps your openbsd session has the erase character set to something other than ctrl-h, or in any case something other than what the BS key sends in minicom. stty -a (assuming similar options to Linux stty) will show you what the tty settings are.

IIRC (it’s over 15 years since I’ve used this on UNIX):

To set the backspace as the “deleting previous character” key, type:

stty erase (after the space after "erase" hit the "backspace" key, enter)

but I’d rather use the method ken_yap describes. The backspace may not be the only thing.