Wyrmsun game does not work

Hi everyone
I installed Wyrmsun game from Yast, when i going to open it from Games menu it dosent load
I’m working on Leap 42.1 machine (which upgraded from 13.2) , Wyrmgus and Wyrmgus-devel already installed
My graphic card is Nvidia Geforce 210 1gb
so i want to know how to fix this problem

I never used this application, but the first thing one should do if an application does not start by using the menu, is to start it from a terminal emulator (like konsole in KDE). Then messages might appear.

Thanks for interest
I tried to run it with terminal by “Wyrmsun” and I got

If 'Wyrmsun' is not a typo you can use command-not-found to lookup the package that cont
ains it, like this:
    cnf Wyrmsun


First some explanation on posting computer text. This is a bit hidden, thus we have to explain to all new members,not just you :wink:

Please do not use PHP tags, but CODE tags. You get them using the # button (somewhere near the PHP button).
And please do copy/paste complete. That is including the prompt, the command, the ouput and the next prompt. Example:

henk@boven:~> Wyrmsun
If 'Wyrmsun' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf Wyrmsun
henk@boven:~> 

Then back to your problem. It is not sure that the program’s name is Wyrmsun. I would rather go for wyrsum because it is very unusual to have capital letters in a program name in Linux… But it might be different alltogether.

You can find out what the icon tries to call. Do you run KDE or a different desktop?

Ok, i’m sorry for that and i’m sorry if l bothering

i did right click on the application icon

http://i.imgur.com/YD9CHpK.png

then used the command “wyrmgus -d /usr/share/wyrmsun” in terminal

**linux-c9pq:/home/NEW #** wyrmgus -d /usr/share/wyrmsun
/home/abuild/rpmbuild/BUILD/Wyrmgus-2.4.0/src/stratagus/script_quest.cpp:198: CclDefineQ
uest: Unsupported tag: BuildUnits
Unsupported tag: BuildUnits
stack traceback:
        [C]: in function 'DefineQuest'
        [string "/usr/share/wyrmsun/scripts/civilizations/ge..."]:87: in main chunk
        [C]: in function 'Load'
        [string "/usr/share/wyrmsun/scripts/quests.lua"]:30: in main chunk
        [C]: in function 'Load'
        [string "/usr/share/wyrmsun/scripts/stratagus.lua"]:2058: in main chunk
**linux-c9pq:/home/NEW #**


and wyrmgus -help

**linux-c9pq:/home/NEW #** wyrmgus -help
Stratagus v2.4.0, Copyright (c) 1998-2015 by The Stratagus Project
  written by Lutz Sammer, Fabrice Rossi, Vladi Shabanski, Patrice Fortier,
  Jon Gabrielson, Andreas Arens, Nehal Mistry, Jimmy Salmon, Pali Rohar,
  cybermind, Andrettin and others.
        https://github.com/Wargus/stratagus
Compile options ZLIB BZ2LIB VORBIS THEORA MIKMOD OPENGL LINUX X11  

Usage: wyrmgus [OPTIONS] [map.smp|map.smp.gz]
        -a              Enables asserts check in engine code (for debugging)
        -c file.lua     Configuration start file (default stratagus.lua)
        -d datapath     Path to stratagus data (default current directory)
        -D depth        Video mode depth = pixel per point
        -e              Start editor (instead of game)
        -E file.lua     Editor configuration start file (default editor.lua)
        -F              Full screen video mode
        -G "options"    Game options (passed to game scripts)
        -h              Help shows this page
        -i              Enables unit info dumping into log (for debugging)
        -I addr         Network address to use
        -l              Disable command log
        -N name         Name of the player
        -o              Do not use OpenGL or OpenGL ES 1.1
        -O              Use OpenGL or OpenGL ES 1.1
        -p              Enables debug messages printing in console
        -P port         Network port to use
        -s sleep        Number of frames for the AI to sleep before it starts
        -S speed        Sync speed (100 = 30 frames/s)
        -u userpath     Path where stratagus saves preferences, log and savegame
        -v mode         Video mode resolution in format <xres>x<yres>
        -W              Windowed video mode
        -x idx          Controls fullscreen scaling if your graphics card supports shade
rs.
                        Pass 1 for nearest-neigubour, 2 for EPX/AdvMame, 3 for HQx, 4 fo
r SAL, 5 for SuperEagle
                        You can also use Ctrl+Alt+/ to cycle between these scaling algor
ithms at runtime.
                        Pass -1 to force old-school nearest neighbour scaling without sh
aders
        -Z              Use OpenGL to scale the screen to the viewport (retro-style). Im
plies -O.
map is relative to StratagusLibPath=datapath, use ./map for relative to cwd
**linux-c9pq:/home/NEW #**

No need to appoligize, your are not bothering.
It is most of the time difficult to have these technical discussions using a forum where we are not sitting both before the computer. But we mostly get there step by step.

You found the correct call indeed. And you used it. It proves that it is there and does something, which is nice to know.

Alas there is some error message I can give no comment on it. Let us hope that others either have experience with the product or else have an Eureka moment on reading the error.

I do not know if there is a site of the product where you can ask for support. You do have some information to go with it now.

Thanks a lot for you :slight_smile:

Hi
There is something funky with the build, I’ve branched the package and will see if can fix…

Hi
All fixed by updating wyrmgus and wyrmsun to version 2.4.2, may take a bit to filter through to the games repo… but will see if can ping someone on IRC to review/accept…

On Tue 06 Sep 2016 07:56:01 AM CDT, WES wrote:

Hi everyone
I installed Wyrmsun game from Yast, when i going to open it from Games
menu it dosent load
I’m working on Leap 42.1 machine (which upgraded from 13.2) , Wyrmgus
and Wyrmgus-devel already installed
My graphic card is Nvidia Geforce 210 1gb
so i want to know how to fix this problem

Hi
Both updates accepted into the games repo, so grab the updated versions
and you should be good to go…


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.27-27-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hello **malcolmlewis
**
i did updating to version 2.4.2 and its working now
http://i.imgur.com/bpxYxU1.png

Thank you very much