wxpython on openSuSE

Hello all,

I was wanting to take some first steps with wxPython… initially its not installed, okay. So I go to the package manager in YaST and there are all sorts of packages w/ ‘wx’ in them, and only one with ‘wxpython’ in it - and it doesn’t look like the right one. I finally found what looked like a reasonable choice, and installed it along with all the dependencies it pulled along with it.

When I went to run a very simple test script that just creates a wxPython frame and nothing else, I got this error message in the console window I ran the script from:

monte@suse:~/Dropbox/Documents/work/temp> python simple.py 
/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py:14512: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")

Can someone help me track this down and fix it?



Honestly, I don’t know what the problem could be, I just tested a wxPython hello world script I got off the internet and it worked just fine. I think the right package is python-wxWidgets-devel.

The error does seem to be that your python bindings have a different version number than the underlying library, not sure what could cause that.

I have just seen the same problem after successfully using wx for years. I have just upgraded to Tumbleweed which seems to have upgraded wxPython and wxWidgets to the latest versions which do not now agree. See iBertus’ comment at https://bbs.archlinux.org/viewtopic.php?id=97284.

Don’t install the python-wxWidgets-devel package - it won’t correct the version mismatch and you will just install lots of unnecessary development headers etc.

The warning message is irritating but my quite complex wxWidgets applications are still running fine.