Wvdial does not recognise my modem

I have been trying to get my modem (Intel 537EP winmodem) to work. I have complied the driver following instructions from the Linmodems website, and received an enormous amount of support from the Linmodems Discussion group (for which I am very grateful).

I have one last problem however. Wvdial will not recognise the modem.

When I run wvdialconf, I get the follwing output:

*Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 – failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 – failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 – and failed too at 115200, giving up.
Modem Port Scan<*1>: S1 S2 S3 S4 S5 S6 S7

Sorry, no modem was detected! Is it in use by another program?
Did you configure it properly with setserial?*

It appears to only scan ttyS0. Under Windows, the modem appears on Com6, so I assume it should be on ttyS5.

I would be grateful for any help.

Thanks in advance

You may want to try working with every TTY device on your system until wvdial hits something. It may take a while, but sometimes modems don’t show up where you think they should. You might also want to check /dev/usb/* if it is a USB modem as there might be something in there. /dev/modem or similar is another possibility.

The configuration should be in a files you are interested in should be:

Just make a list of the things you suspect could work and strike each one off until you find something that does. That’s what I had to do with my modem back in the day.

Also here’s the wikipedia article on wvdial to get you started:

No, I don’t miss dial-up one bit!

Thanks Faolan.

I agree with your comments about dial-up! Thankfully, I only need to get this working so that I can send/receive the occasional fax (apparently some people still use them!!!).

Just a thought, (I’m not faniliar with this hardware or the driver needed to support it), but does yast > hardware > modems detect the device? If you can configure it from there, then kppp or kinternet dialers should be ok to use.

Does /dev/modem exist?

ls -l /dev/modem

I honestly didn’t think people still used dial-up anymore. I haven’t seen an add for dial-up on TV in forever (then again I don’t watch much TV) nor have I AOL discs in the mail for several years now.

Does anyone still get those? :stuck_out_tongue: My grandmother uses them to keep birds out of her garden. Apparently they don’t like dial-up either.

Thanks for your replies.

I just need dial-up to send/receive faxes - the last application I have to use Windows for!

I have tried all the solutions recommended, but without success, so I’m about to stop wasting time and effort, get a Linux compatible unit, and dump the winmodem.

Thanks again for all your help.