Wrong xmgrace file association

I’ve noticed that since a few OpenSuse versions the xmgrace files *.agr are wrongly associated in KDE file manager Dolphin to text editors and thus opened as text files in eg. kate or kwrite rather than in xmgrace showing plots. I’ve tried to manipulate in File Type Options (Filename Pattern and/or Application Preference Order) but to no avail.

Any ideas ?



Try changing the file association from System Settings, rather than from within Dolphin. (I’ve seen a similar problem in the past, forgotten what the file type was, but I know it wasn’t *.agr as I don’t use xmgrace).

(KDE) System Settings -> Applications -> File Associations

If the setting currently looks OK, try deleting that association, then log out/in and recreate it. I’ll try to find the notes I made at the time :\ …

Woooo hoooo.

Now it works. It turns out that there was no association for *.agr extension with xmgrace. Added it and voila. Even the relogging was not necessary.

Thanks a lot.