Wrong Video Resolution mode on Gateway nv51m

Hi.
I just made a fresh new install with OS 13.1 GNOME x86 on a Gateway nv51m with a Intel GMA 4500MHD GPU… I had to add the “nomodeset=0” boot option in order to have a working screen.
This prblem I also had it with OS 12.3 but could fix it with a workaround but I dont find it now.

This is my lspci line:

michelle@linux-x41i:~> sudo /sbin/lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
michelle@linux-x41i:~> 

and my kernel line:

michelle@linux-x41i:~> uname -a
Linux linux-x41i.site 3.11.6-4-default #1 SMP Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) i686 i686 i386 GNU/Linux
michelle@linux-x41i:~> 

I used the GNOME Live installer and checked the mdsum which was fine and It seems that the screen settings does not recognize the video as it appears to be “Unknown” in the control center and I only have the 1024 x 768 option with 4:1 size.
Can anyone give me a hint on how to solve this problem?
Thanks in advance

Luis

Of course.
With “nomodeset” you prevent the intel driver from being used.
You’re using the fbdev driver now which doesn’t fetch information from the monitor and uses a default resolution of 1024x768.

You could change the resolution in YaST->System->Boot Loader->Boot Loader Options->Console resolution.

BUT:
Today a new intel driver was released as online update, which fixes some issues/crashes.
So I would suggest to install all updates and then try again without “nomodeset”.

I tried without nomodeset and I got a black screen, made a zypper dup but nothing seemed to happen. Or maybe I must install the new Intell driver manually?

EDIT: Should I do what stands in this post: https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/477362-back-light-fix-black-screen-intel-4500-hd-laptops.html before deleting the nomode set option??
Thanks n advance

Luis

You shouldn’t use “zypper dup” to install the updates. “zypper up” or “zypper patch” (or YaST->Online Update or the update applet) should be enough to get the intel driver update.

Which one do you have installed now?

rpm -qi xf86-video-intel

I do not know if the newer intel driver does indeed fix your particular problem, I just wanted to suggest to try it.

EDIT: Should I do what stands in this post: https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/477362-back-light-fix-black-screen-intel-4500-hd-laptops.html before deleting the nomode set option??
Thanks n advance

Not sure about that, but you could try this as well if the updated intel driver still doesn’t work.

Hi. thanks for your prompt response:
here is the command:

michelle@linux-x41i:~> rpm -qi xf86-video-intel
Name        : xf86-video-intel
Version     : 2.99.906
Release     : 4.1
Architecture: i586
Install Date: lun 25 nov 2013 08:05:59 CST
Group       : System/X11/Servers/XF86_4
Size        : 2022545
License     : MIT
Signature   : RSA/SHA256, lun 25 nov 2013 04:27:20 CST, Key ID b88b2fd43dbdc284
Source RPM  : xf86-video-intel-2.99.906-4.1.src.rpm
Build Date  : lun 18 nov 2013 06:30:06 CST
Build Host  : build15
Relocations : (not relocatable)
Packager    : http://bugs.opensuse.org
Vendor      : openSUSE
URL         : http://xorg.freedesktop.org/
Summary     : Intel video driver for the Xorg X server
Description :
intel is an Xorg driver for Intel integrated video cards.

The driver supports depths 8, 15, 16 and 24. All visual types are
supported in depth 8. For the i810/i815 other depths support the
TrueColor and DirectColor visuals. For the i830M and later, only the
TrueColor visual is supported for depths greater than 8. The driver
supports hardware accelerated 3D via the Direct Rendering Infrastructure
(DRI), but only in depth 16 for the i810/i815 and depths 16 and 24 for
the 830M and later.
Distribution: openSUSE 13.1
michelle@linux-x41i:~> 


I tried the suggestion on the other thread and it seems to work. My display resolution is not blurry anymore and the characters look very nice now
Thanks in advance
Luis

OK, this is the new driver.

I tried the suggestion on the other thread and it seems to work. My display resolution is not blurry anymore and the characters look very nice now

So it works now without “nomodeset”?
Great. :slight_smile:

But it’s good for you none-the-less to have the newer intel driver as well. The old one caused some crashes.

Yes. It’s working without “nomodeset”, in fact, it disappeared from the boot line (I did not delet it).

My resolution is the correct one also the size has changed to 16:9 which is the correct one.

Thanks so much for your time.

@admin, please mark this thread as solved. TIA

Well, if you only added the option at the boot screen it won’t get saved.

@admin, please mark this thread as solved. TIA

They don’t do that here.
Adding a “(SOLVED)” or similar to the thread’s title (as you did) is just fine… :wink: