wrong resolution

Hi

I have problem with resoltion ( @gnom desktop ).

In Yast → videocard & monitor is all right. There is correct resolution 1366x768 ( WXGA ). Also the videocard ( I don’t have really one, only chipset “Intel Mobile GM45” ) is correct recognized. But Monitor is’t recognized, and I don’t know which one I have ( It’s notebook from acer ).

Nevertheless if I go direct in monitor preferences ( at the bottom the monitor with a ruler symbol ) the resolution is set to 800x600 and I can only change to 640x480. the monitor is as 15" recognized ( I have 15.4", even a bit more broadly - 1366x768 ) and now I don’t know what to do.

All symbols, all programs, everything is huge! How is it possible to configure the correct one resolution?

I am no expert, but maybe I could give you some hints while real help is on the way (especially until it will get bright again in and from the USA).

I think mostly things like that (right resolution of a laptop monitor also with GNOME) are discussed in the subforum “Hardware”.

I guess during your installation the right graphic driver was not chosen or did not work and your system fell back to a really ancient one: both the resolutions your “Display Preferences” offered you are not only for low resolution but also for a 4:3 monitor not for the new cinema like 16:9 monitors.
Maybe you could try to understand this form user “oldcpu” article and try to define which driver is in use now:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

And maybe you could help the experts helping you if you post your version of openSUSE (11.2?) and the precise model of your laptop?
Did you check if your data was integer before the installation?

Good luck!
pistazienfresser

It is possible that the intel driver is not in use. Read the guide as suggested by pistazienfresser. If the problem still remains after trying things mentioned there, then send us the link to the URL provided by pastebin with your /var/log/Xorg.0.log contents. This may reveal the exact problem to us.

Do you have /etc/X11/xorg.conf present? (You may not, as its not usually required now)

cat /etc/X11/xorg.conf

It may be necessary to create (or edit) xorg.conf with appropriate monitor settings, and a modeline for 1366x768 display mode.

I have same resolution 1366x768 and GM45 chipset, but on Lenovo notebook. I have the “intel” driver automatically loaded by X and no xorg.conf. This is on 11.2 64bit/KDE 4.3.5 though. The modesetting is correct for 1366x768 and works fine. BTW you didn’t tell us your openSUSE version/release.

The Xorg.0.log should show the problem. You should see lines showing “intel” like this small sample:

(==) intel(0): Depth 24, (--) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) GM45
(--) intel(0): Chipset: "GM45"
(--) intel(0): Linear framebuffer at 0xD0000000

If you have the same intel driver loaded.

Further down it shows this:

(II) intel(0): EDID vendor "LEN", prod id 16560
(II) intel(0): Output VGA disconnected
(II) intel(0): Output LVDS connected
(II) intel(0): Output HDMI-1 disconnected
(II) intel(0): Using exact sizes for initial modes
(II) intel(0): Output LVDS using initial mode 1366x768

thx for answers

My linux version is openSuse 11.1 - 2.6.27.7-9 updated to last version ( a few days ago )

I have only /etc/x11/xorg.conf file, not the xorg.0.log

Here are the monitor settings from xorg.conf file - it seems to be all right


Section "Monitor"
  DisplaySize  344 194
  HorizSync    30-40
  Identifier   "Monitor[0]"
  ModelName    "Unknown"
  Option       "DPMS"
  Option       "PreferredMode" "1366x768"
  VendorName   "Unknown"
  VertRefresh  50-75
  UseModes     "Modes[0]"
EndSection

And I still don’t know what to do:O

I did it! rotfl!

I simple set the monitor to LCD1366x768@68Hz and it works now!

Thanks for the update. It often comes down to selecting the correct monitor type.

As it was, your xorg.conf HorizSync value was too low. (It would need to have a higher range to cope with the 60kHz horizontal freq associated with 1366x768@60Hz for example).

The Xorg.0.log file is located in the /var/log/ directory.