Wrong resolution

I’m using openSUSE 11.1 with KDE 4.3dev for a while now, but my resolution is always wrong. When I set it to 1024x768, everything is too big, and when set to 1280x1024 (like I do now since that seems to be the best for now), everything is a little small and there is a ugly black strip on the right side of the screen. So I guess the resolution needs to be 1280x800, but that’s not an option.

My videocard:

Intel Extreme Graphics 2 (integrated with Intel 865G chipset)

Does anyone know a solution for this problem?

What driver is being used by the kernel:
su terminal do:

lspci -k

post the part about the graphics

The output:

linux-08hg:/home/hobbub # lspci -k         
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
        Kernel driver in use: agpgart-intel                                                   
        Kernel modules: intel-agp                                                             
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
        Kernel modules: intelfb

Try generic LCD setting in yast and see if that offers the res.

Do you mean the one in System Settings (Configure desktop)?

Graphics and Monitor

This is mine but my monitor is recognized by default

Trying a generic LCD may get you there

Hmm, Yast seems to recognize my monitor too. And when I set the resolution in Yast to the desired one, nothing changes. A generic LCD also makes no difference.

Did you log out and back in?

After logging out and back in again, the fonts are te size they need to be. But there are still big, ugly, black borders around the desktop :frowning:

Go back and check what you have in Yast again. Has it changed from what you set?

What details show in the MyComputer/sysinfo section for the screen;
Mine is

Vendor: Tungsten Graphics, Inc
Model: Mesa DRI Intel(R) 965GM 20080716 x86/MMX/SSE2
Driver: 1.4 Mesa 7.2

Please try going to runlevel 3 (init 3) and as su run sax2 -r -m 0=intel
When you get to runlevel 5 use yast2 to fine tune the monitor etc.

I’m sorry for the late reply, but this problem is solved now. I bought a new monitor and it picked up that monitors resolution just fine :smiley: